diff mbox series

[bug#68580,1/2] gnu: python-osmnx: Update to 1.8.1.

Message ID 87o7dhu2en.fsf@troyfigiel.com
State New
Headers show
Series gnu: python-osmnx: Update to 1.8.1. | expand

Commit Message

Troy Figiel Jan. 19, 2024, 8:37 a.m. UTC
* gnu/packages/geo.scm (python-osmnx): Update to 1.8.1.
[arguments]<#:test-flags>: Add test_geocoder and test_features to ignored
tests. Remove test_geocode_to_df and test_geometries from ignored tests.
[propagated-inputs]: Remove python-pyproj and python-rtree.
[native-inputs]: Add python-hatchling, remove python-numpy.
---
 gnu/packages/geo.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 14e2d9f16b..04166c8c53 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -977,7 +977,7 @@  (define-public python-geopandas
 (define-public python-osmnx
   (package
     (name "python-osmnx")
-    (version "1.1.2")
+    (version "1.8.1")
     (source
      (origin
        ; Fetch from github as the pypi package is missing the tests dir.
@@ -987,7 +987,7 @@  (define-public python-osmnx
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1n8qjn184p5a2s3j6x6iyc1i7p3l3xnbqqxm6ajwgwv6j5fw1d5a"))))
+        (base32 "0n238n07pp5jw9cg8nqw9qhpkw8plzb5imz1gxbliw2l1idqyjcl"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -995,8 +995,8 @@  (define-public python-osmnx
       '(list "-k"
              (string-append
                ;; The following tests require network access.
-               "not test_geocode_to_gdf"
-               " and not test_stats"
+               "not test_stats"
+               " and not test_geocoder"
                " and not test_osm_xml"
                " and not test_elevation"
                " and not test_routing"
@@ -1005,7 +1005,7 @@  (define-public python-osmnx
                " and not test_api_endpoints"
                " and not test_graph_save_load"
                " and not test_graph_from_functions"
-               " and not test_geometries"))))
+               " and not test_features"))))
     (propagated-inputs
       (list python-folium
             python-geopandas
@@ -1013,12 +1013,10 @@  (define-public python-osmnx
             python-networkx
             python-numpy
             python-pandas
-            python-pyproj
             python-requests
-            python-rtree
             python-shapely))
     (native-inputs
-      (list python-numpy python-pytest))
+      (list python-hatchling python-pytest))
     (home-page "https://github.com/gboeing/osmnx")
     (synopsis
       "Retrieve, model, analyze, and visualize OpenStreetMap street networks")