[bug#71024] Update diffoscope to 267 (with xz bonus update)
Commit Message
From 1aabeef6612d8b3df66db9bbda7f44896f1a5c94 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Fri, 17 May 2024 18:33:04 -0700
Subject: [PATCH 1/2] gnu: Add xz-5.4 variant.
* gnu/packages/compression.scm (xz-5.4): New variable.
---
gnu/packages/compression.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)
@@ -573,6 +573,21 @@ (define-public xz
(license (list license:gpl2+ license:lgpl2.1+)) ; bits of both
(home-page "https://tukaani.org/xz/")))
+(define-public xz-5.4
+ (package
+ (inherit xz)
+ (name "xz-5.4")
+ (version "5.4.5")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "http://tukaani.org/xz/xz-" version
+ ".tar.gz")
+ (string-append "http://multiprecision.org/guix/xz-"
+ version ".tar.gz")))
+ (sha256
+ (base32
+ "1mmpwl4kg1vs6n653gkaldyn43dpbjh8gpk7sk0gps5f6jwr0p0k"))))))
+
(define-public lhasa
(package
(name "lhasa")
base-commit: e9b25a6c6c626a560d28a1f732e6e5d362d584a4
--
2.39.2