bug#76363: [PATCH v1] gnu: Add python-pytooling.
Commit Message
Cayetano Santos <csantosb@inventati.org> skribis:
> * gnu/packages/python-xyz.scm (python-pytooling): New variable.
>
> Change-Id: Id045f071b6c531d4afff4322d1a544589f214d50
Applied with the changes below, with the description adapted from
upstream’s.
Thanks,
Ludo’.
@@ -2606,10 +2606,12 @@ (define-public python-pytooling
`(#:tests? #f)) ; requires recent versions of mypy and lxml
(native-inputs (list python-setuptools python-wheel))
(home-page "https://pytooling.github.io/pyTooling/")
- (synopsis "Miscellaneous python tools")
+ (synopsis "Miscellaneous Python tools")
(description
- "@code{pyTooling} is a collection of arbitrary useful classes,
-decorators, meta-classes and exceptions.")
+ "pyTooling is a collection of (abstract) data models, lacking classes,
+decorators, a new performance boosting meta-class, and enhanced exceptions.
+It also provides lots of helper functions---e.g., to ease the handling of
+package descriptions or to unify multiple existing APIs into a single API.")
(license license:asl2.0)))
(define-public python-colorlog