[bug#34396] gnu: Add python-pymsgbox.

Message ID 87mun5vh90.fsf@ponder
State Accepted
Headers show
Series [bug#34396] gnu: Add python-pymsgbox. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Vagrant Cascadian Feb. 9, 2019, 2:16 a.m. UTC
* gnu/packages/python-xyz.scm (python-pymsgbox): New variable.
---
 gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Danny Milosavljevic Feb. 11, 2019, 9:52 a.m. UTC | #1
Hi Vagrant,

thanks.  Applied to master.

On Fri, 08 Feb 2019 18:16:11 -0800
Vagrant Cascadian <vagrant@debian.org> wrote:

> +              ;; LICENSE.txt is not present on pypi
> +              (url "https://github.com/asweigart/PyMsgBox")
> +              (commit "55926b55f46caa969c5ddb87990ebea2737bd66f")))

Hmm, could you report this upstream?

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 14a80b920e..086eb3af26 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1938,6 +1938,44 @@  easier to build concurrent applications.")
 (define-public python2-pykka
   (package-with-python2 python-pykka))
 
+(define-public python-pymsgbox
+  (package
+    (name "python-pymsgbox")
+    (version "1.0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              ;; LICENSE.txt is not present on pypi
+              (url "https://github.com/asweigart/PyMsgBox")
+              (commit "55926b55f46caa969c5ddb87990ebea2737bd66f")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0zy7rjfpwlrd8b64j7jk2lb8m2npc21rnpwakpfvwgl4nxdy80rg"))))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         ;; Circular dependency to run tests:
+         ;; Tests need pyautogui, which depends on pymsgbox.
+         (delete 'check))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/asweigart/PyMsgBox")
+    (synopsis
+     "Python module for JavaScript-like message boxes")
+    (description
+     "PyMsgBox is A simple, cross-platform, pure Python module for
+JavaScript-like message boxes.  Types of dialog boxes include:
+@enumerate
+@item alert
+@item confirm
+@item prompt
+@item password
+@end enumerate
+")
+    (license license:bsd-3)))
+
 (define-public python-pympler
   (package
     (name "python-pympler")