diff mbox series

[bug#35878] gnu: Add chafa.

Message ID 87muj8t0em.fsf@gnu.org
State Accepted
Headers show
Series [bug#35878] gnu: Add chafa. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès May 27, 2019, 2:52 p.m. UTC
Hi,

guy fleury iteriteka <hoonandon@gmail.com> skribis:

> * gnu/packages/image-viewers.scm(chaffa): New variable.

I’d suggest the changes below.

Additionally, this code detects SSE4.1 and related instruction set
extensions at configuration time.  As a result, I think the resulting
code may not run on all x86_64 machines.

Could you investigate this and see how we can get a generic binary?

Thanks,
Ludo’.

Comments

guy fleury iteriteka May 29, 2019, 7:44 a.m. UTC | #1
Hi,

I will try!
Le 27 mai 2019 16:52, "Ludovic Courtès" <ludo@gnu.org> a écrit :

> Hi,
>
> guy fleury iteriteka <hoonandon@gmail.com> skribis:
>
> > * gnu/packages/image-viewers.scm(chaffa): New variable.
>
> I’d suggest the changes below.
>
> Additionally, this code detects SSE4.1 and related instruction set
> extensions at configuration time.  As a result, I think the resulting
> code may not run on all x86_64 machines.
>
> Could you investigate this and see how we can get a generic binary?
>
> Thanks,
> Ludo’.
>
>
guy fleury iteriteka June 29, 2019, 3:23 p.m. UTC | #2
Hello Ludovic,

Sorry for taking so long time.
I discus with the developper upstream. Here is what he tells me:
---------------------------------
Even if it builds SSE support, it will only be used at runtime if the
platform supports it. It uses CPUID internally to detect the CPU
capabilities when run.
-------------------------------

He will also add a note to clarify things in the next release!

Thanks.
Le 29 mai 2019 09:44, "guy fleury iteriteka" <hoonandon@gmail.com> a écrit :

> Hi,
>
> I will try!
> Le 27 mai 2019 16:52, "Ludovic Courtès" <ludo@gnu.org> a écrit :
>
>> Hi,
>>
>> guy fleury iteriteka <hoonandon@gmail.com> skribis:
>>
>> > * gnu/packages/image-viewers.scm(chaffa): New variable.
>>
>> I’d suggest the changes below.
>>
>> Additionally, this code detects SSE4.1 and related instruction set
>> extensions at configuration time.  As a result, I think the resulting
>> code may not run on all x86_64 machines.
>>
>> Could you investigate this and see how we can get a generic binary?
>>
>> Thanks,
>> Ludo’.
>>
>>
Ludovic Courtès July 2, 2019, 3:19 p.m. UTC | #3
Hi guy,

guy fleury iteriteka <hoonandon@gmail.com> skribis:

> Sorry for taking so long time.
> I discus with the developper upstream. Here is what he tells me:
> ---------------------------------
> Even if it builds SSE support, it will only be used at runtime if the
> platform supports it. It uses CPUID internally to detect the CPU
> capabilities when run.
> -------------------------------

Oh indeed, I see that ‘chafa-features.h’ does the right thing.

Applied, thanks for checking!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index fc94242ac6..d947f2d7eb 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -446,12 +446,12 @@  including CBZ, CB7, CBT, LHA.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("glib"        ,glib)
+     `(("glib" ,glib)
        ("imagemagick" ,imagemagick)))
-    (synopsis "Terminal Graphics for the 21st Century")
+    (synopsis "Convert images to ANSI/Unicode characters")
     (description
-     "Chafa is a command-line utility that converts all kinds of images, 
-including animated GIFs, into ANSI/Unicode character output that can be 
+     "Chafa is a command-line utility that converts all kinds of images,
+including animated GIFs, into ANSI/Unicode character output that can be
 displayed in a terminal.")
     (home-page "https://hpjansson.org/chafa/")
     (license license:lgpl3+)))