diff mbox series

[bug#36043] Add Geany

Message ID 87muj1vvds.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#36043] Add Geany | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Nicolas Goaziou June 1, 2019, 9:38 p.m. UTC
Hello,

The following patch adds Geany text editor.

Regards,

Comments

Arun Isaac June 4, 2019, 12:25 p.m. UTC | #1
Please add a copyright header with your name and email address.

The scintilla library comes bundled with geany. Is it possible to
unbundle it?

> +    (inputs
> +     `(("gtk2" ,gtk+-2)))

Geany supports gtk3. Could you build with that?

> +    (home-page "https://www.geany.org")
> +    (synopsis "Small and lightweight IDE")

> +    (description "Geany is a small and lightweight Integrated
> +Development Environment.  It was developed to provide a small and fast
> +IDE, which has only a few dependencies from other packages.  Another
> +goal was to be as independent as possible from a special Desktop
> +Environment like KDE or GNOME.

Perhaps rewrite this as:

Geany is a small and fast Integrated Development Environment (IDE) that
only has a few dependencies on other packages and is as independent as
possible from special desktop environments like KDE or GNOME.

> Geany only requires the GTK2 runtime libraries.

I think we should not mention this in the description, especially if we
are building with gtk3.

> +Some basic features of Geany:
> +@itemize
> +@item Syntax highlighting
> +@item Code folding
> +@item Symbol name auto-completion
> +@item Construct completion/snippets
> +@item Auto-closing of XML and HTML tags
> +@item Call tips
> +@item Many supported filetypes including C, Java, PHP, HTML, Python,
> +      Perl, Pascal (full list)

What is (full list) ?

LGTM otherwise, thanks!
diff mbox series

Patch

From e626c1e11d0f181690e2d2a716a5d40fd85e874b Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Sat, 1 Jun 2019 23:37:24 +0200
Subject: [PATCH] gnu: Add geany.

* gnu/packages/text-editors.scm (geany): New variable.
---
 gnu/packages/text-editors.scm | 44 +++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 534934dfd1..617e61ea27 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -389,3 +389,47 @@  projects.  The EditorConfig project maintains a file format and plugins for
 various text editors which allow this file format to be read and used by those
 editors.")
     (license license:bsd-2)))
+
+(define-public geany
+  (package
+    (name "geany")
+    (version "1.35")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://download.geany.org/"
+                                  "geany-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "179xfnvhcxsv54v2mlrhykqv2j7klniln5sffvqqpjmdvwyivvim"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gtk2" ,gtk+-2)))
+    (home-page "https://www.geany.org")
+    (synopsis "Small and lightweight IDE")
+    (description "Geany is a small and lightweight Integrated
+Development Environment.  It was developed to provide a small and fast
+IDE, which has only a few dependencies from other packages.  Another
+goal was to be as independent as possible from a special Desktop
+Environment like KDE or GNOME.  Geany only requires the GTK2 runtime
+libraries.
+
+Some basic features of Geany:
+@itemize
+@item Syntax highlighting
+@item Code folding
+@item Symbol name auto-completion
+@item Construct completion/snippets
+@item Auto-closing of XML and HTML tags
+@item Call tips
+@item Many supported filetypes including C, Java, PHP, HTML, Python,
+      Perl, Pascal (full list)
+@item Symbol lists
+@item Code navigation
+@item Build system to compile and execute your code
+@item Simple project management
+@item Plugin interface
+@end itemize")
+    (license license:gpl2+)))
-- 
2.21.0