diff mbox series

[bug#37317] Add emacs-flyspell-grammalecte

Message ID 87mufipcda.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#37317] Add emacs-flyspell-grammalecte | expand

Commit Message

Nicolas Goaziou Sept. 5, 2019, 11:11 p.m. UTC
Hello,

The following patch adds emacs-flyspell-grammalecte.

Feedback welcome.

Regards,

Comments

Nicolas Goaziou Sept. 6, 2019, 7:09 a.m. UTC | #1
Completing myself,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> +         (add-after 'install 'link-to-grammalecte
> +           ;; The package expects grammalecte to be in a sub-directory.
> +           ;; Symlink it there from the store.
> +           (lambda* (#:key inputs outputs #:allow-other-keys)
> +             (let ((grammalecte (assoc-ref inputs "grammalecte"))
> +                   (out (assoc-ref outputs "out"))
> +                   (version ,(version-major+minor (package-version python))))
> +               (with-directory-excursion
> +                   (string-append out
> +                                  "/share/emacs/site-lisp/guix.d/"
> +                                  "flycheck-grammalecte-" ,version)
> +                 (symlink (string-append grammalecte "/lib/"
> +                                         "python" version "/site-packages/"
> +                                         "grammalecte")
> +                          "grammalecte"))))))))

I forgot a #t here. I'll add it. I'm not sending the updated patch.

> +    (inputs
> +     `(("grammalecte" ,grammalecte)
> +       ("python" ,python)))
> +    (propagated-inputs
> +     `(("emacs-flycheck" ,emacs-flycheck)))
> +    (home-page "https://git.deparis.io/flycheck-grammalecte/")
> +    (synopsis "Integrate Grammalecte with Flycheck")
> +    (description "Integrate the French grammar and typography checker
> +Grammalecte with Flycheck to automatically look for mistakes in your
> +writings. It also provides an easy way to find synonyms and antonyms for

Missing space here. Also fixed.
Ludovic Courtès Sept. 26, 2019, 9:11 p.m. UTC | #2
Hi Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

>>From d362da36f369d0bf98d49c484ce9fd6b0603b5b2 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Fri, 6 Sep 2019 01:10:10 +0200
> Subject: [PATCH] gnu: Add emacs-flycheck-grammalecte.
>
> * gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte): New variable.

LGTM, thanks!

Ludo’.
Nicolas Goaziou Sept. 27, 2019, 7:48 p.m. UTC | #3
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> LGTM, thanks!

Applied. Thank you!

Regards,
diff mbox series

Patch

From d362da36f369d0bf98d49c484ce9fd6b0603b5b2 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 6 Sep 2019 01:10:10 +0200
Subject: [PATCH] gnu: Add emacs-flycheck-grammalecte.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte): New variable.
---
 gnu/packages/emacs-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8f866fbc28..7ca3f8e4ca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -88,6 +88,7 @@ 
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages code)
   #:use-module (gnu packages databases)
+  #:use-module (gnu packages dictionaries)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages gtk)
@@ -3076,6 +3077,59 @@  boundaries defined by syntax highlighting.")
 for Flow files.")
       (license license:gpl3+))))
 
+(define-public emacs-flycheck-grammalecte
+  (package
+    (name "emacs-flycheck-grammalecte")
+    (version "0.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://git.deparis.io/"
+                                  "flycheck-grammalecte/snapshot/"
+                                  "flycheck-grammalecte-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0wjm9xyra870pci4bcrbnc9x66x18mi7iz08rkxa4clxv28xzryb"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:include '("\\.(el|py)$")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-python
+           ;; Hardcode python3 executable in the Emacs library.
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((python3 (string-append (assoc-ref inputs "python")
+                                           "/bin/python3")))
+               (substitute* "flycheck-grammalecte.el"
+                 (("python3") python3))
+               #t)))
+         (add-after 'install 'link-to-grammalecte
+           ;; The package expects grammalecte to be in a sub-directory.
+           ;; Symlink it there from the store.
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((grammalecte (assoc-ref inputs "grammalecte"))
+                   (out (assoc-ref outputs "out"))
+                   (version ,(version-major+minor (package-version python))))
+               (with-directory-excursion
+                   (string-append out
+                                  "/share/emacs/site-lisp/guix.d/"
+                                  "flycheck-grammalecte-" ,version)
+                 (symlink (string-append grammalecte "/lib/"
+                                         "python" version "/site-packages/"
+                                         "grammalecte")
+                          "grammalecte"))))))))
+    (inputs
+     `(("grammalecte" ,grammalecte)
+       ("python" ,python)))
+    (propagated-inputs
+     `(("emacs-flycheck" ,emacs-flycheck)))
+    (home-page "https://git.deparis.io/flycheck-grammalecte/")
+    (synopsis "Integrate Grammalecte with Flycheck")
+    (description "Integrate the French grammar and typography checker
+Grammalecte with Flycheck to automatically look for mistakes in your
+writings. It also provides an easy way to find synonyms and antonyms for
+a given word (to avoid repetitions for example).")
+    (license license:gpl3+)))
+
 (define-public emacs-elisp-demos
   (package
     (name "emacs-elisp-demos")
-- 
2.23.0