diff mbox series

[bug#40190] Linux-Libre 5.5.x

Message ID 87mu7xg34t.fsf@ponder
State Accepted
Headers show
Series [bug#40190] Linux-Libre 5.5.x | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vagrant Cascadian March 30, 2020, 5:32 p.m. UTC
On 2020-03-22, Vagrant Cascadian wrote:
> On 2020-03-22, Vagrant Cascadian wrote:
>> On 2020-03-19, Vagrant Cascadian wrote:
>>> So far, I haven't had time to test and update linux-libre 5.5 with the
>>> kernel configs and so on, so I've been working on a
>>> linux-libre-arm64-generic package that uses the defconfig (much like
>>> linux-libre-arm-generic) and linux-libre 5.5.x.
>>
>> I was able to test linux-libre 5.5.10 on x86_64 by copying the 5.4
>> kernel config over to 5.5 and building, and it seemed to work fine.

I was advised to regenerate the kernel configs using "make oldconfig",
but there was nothing obvious *to me* to change, and I ended up hitting
enter the whole way through... so leaving with these for now.


>> I also did a build of linux-libre-arm-generic using 5.5.10, and it
>> seemed to work fine as well.
>>
>> It also occurs to me that it would be nice to get a newer kernel into
>> the upcoming release, unless there's a reason not to...
>
> Updated patch series, which also includes updating the default
> linux-libre to 5.5.

The pinebook pro portions have already been merged for 5.4.x, and still
apply to 5.5.x.

Attached is the first patch of an updated series for linux-libre 5.5.13,
following up with a second patch to actually switch the default to
5.5.x.  Boot tested on x86_64.

I'm tempted to at least merge the first patch and create a
linux-libre-arm64-generic-5.5 package until it switches to the
default...


live well,
  vagrant
diff mbox series

Patch

From 5f846e37c42ad827e5ef40f3eb7139dc054db5da Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sat, 14 Mar 2020 18:54:50 -0700
Subject: [PATCH 1/2] gnu: Add linux-libre 5.5.

* gnu/packages/linux (deblob-scripts-5.5): New variable.
  (linux-libre-5.5-version): New variable.
  (linux-libre-5.5-pristine-source): New variable.
  (linux-libre-5.5-source): New variable.
  (linux-libre-headers-5.5): New variable.
  (linux-libre-5.5): New variable.
---
 gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 701df764cd..6b406f8dc5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -192,6 +192,12 @@  defconfig.  Return the appropriate make target if applicable, otherwise return
                               "deblob-check"))
           (sha256 deblob-check-hash))))
 
+(define deblob-scripts-5.5
+  (linux-libre-deblob-scripts
+   "5.5.13"
+   (base32 "1vj3rnrbkhj86lkabhrcm8qiqcz1lqi0lk54ysmg3lanf2vqgvab")
+   (base32 "1r87n60a1ksajqvkra55w4fa2iwsbhys3id8z2j179429pm0ybwn")))
+
 (define deblob-scripts-5.4
   (linux-libre-deblob-scripts
    "5.4.28"
@@ -362,6 +368,14 @@  corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
                         "linux-" version ".tar.xz"))
     (sha256 hash)))
 
+(define-public linux-libre-5.5-version "5.5.13")
+(define-public linux-libre-5.5-pristine-source
+  (let ((version linux-libre-5.5-version)
+        (hash (base32 "1qjf18qywzrfdzwpgpf6m0w0bil8rbc9hby8473ckzvbl0a3cfqz")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-5.5)))
+
 (define-public linux-libre-5.4-version "5.4.28")
 (define-public linux-libre-5.4-pristine-source
   (let ((version linux-libre-5.4-version)
@@ -430,6 +444,15 @@  corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-5.5-source
+  (source-with-patches linux-libre-5.5-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch
+                             ;; Pinebook Pro patch from linux-next,
+                             ;; can be dropped for linux-libre 5.7
+                             (search-patch
+                              "linux-libre-support-for-Pinebook-Pro.patch"))))
+
 (define-public linux-libre-5.4-source
   (source-with-patches linux-libre-5.4-pristine-source
                        (list %boot-logo-patch
@@ -529,6 +552,10 @@  corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-5.5
+  (make-linux-libre-headers* linux-libre-5.5-version
+                             linux-libre-5.5-source))
+
 (define-public linux-libre-headers-5.4
   (make-linux-libre-headers* linux-libre-5.4-version
                              linux-libre-5.4-source))
@@ -793,6 +820,12 @@  It has been modified to remove all non-free binary blobs.")
 ;;; Generic kernel packages.
 ;;;
 
+(define-public linux-libre-5.5
+  (make-linux-libre* linux-libre-5.5-version
+                     linux-libre-5.5-source
+		     '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-5.4
   (make-linux-libre* linux-libre-5.4-version
                      linux-libre-5.4-source
-- 
2.20.1