diff mbox series

[bug#40417] Add emacs-magit-annex

Message ID 87mu6vu1bn.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#40417] Add emacs-magit-annex | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 28, 2020, 2:33 p.m. UTC
Kyle Meyer writes:

> This one points to a real problem, though you'd only see it when calling
> the command magit-annex-unused-log.  Magit renamed magit-git-log to
> magit-log-setup-buffer.  Magit-annex's master tracks Magit's, so it uses
> the new name, but the former is what is in the commit that Guix's Magit
> is built from.  I've pushed a compatibility kludge to Magit-annex so
> that it will fall back to the old name.
>
> Could you squash this commit into your commit?
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index c56766047d..b4c12f57ea 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -476,7 +476,7 @@ (define-public emacs-magit-popup
>      (license license:gpl3+)))
>  
>  (define-public emacs-magit-annex
> -  (let ((commit "0bc96737634e78ac7c7f8a3f73190531c0890914")
> +  (let ((commit "ef5dce6267e9118a5eca82a22bcad0b67826c23a")
>          (revision "1"))
>      (package
>        (name "emacs-magit-annex")
> @@ -489,7 +489,7 @@ (define-public emacs-magit-annex
>                  (file-name (git-file-name name version))
>                  (sha256
>                   (base32
> -                  "1lm8412n2046fz8n7rfbadyww2074lsxq0w4gm1x1alraz5im5h4"))))
> +                  "0vzkydgl889cq173zjl89g2vrddb9abc4a8gljiz3b4a7n5b1nrd"))))
>        (build-system emacs-build-system)
>        (propagated-inputs
>         `(("magit" ,emacs-magit)

Done.  The messages are gone, yay!

Is it good to push now then, I'd assume?

 - Chris

PS: I didn't realize you were a (the?) developer of the package I'm
submitting to Guix, and doing the review!  That's wonderful!

Comments

Kyle Meyer April 28, 2020, 2:47 p.m. UTC | #1
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

> Is it good to push now then, I'd assume?

Thanks for the update.  All good from my point of view.

> PS: I didn't realize you were a (the?) developer of the package I'm
> submitting to Guix, and doing the review!  That's wonderful!

:>
Christine Lemmer-Webber April 28, 2020, 4:31 p.m. UTC | #2
Kyle Meyer writes:

> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> Is it good to push now then, I'd assume?
>
> Thanks for the update.  All good from my point of view.

Yay, it's in!

>> PS: I didn't realize you were a (the?) developer of the package I'm
>> submitting to Guix, and doing the review!  That's wonderful!
>
> :>

:> :D
diff mbox series

Patch

From 0e7c9c1236a60dbe96c7a9bc19c9e1cf2ba342e7 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Thu, 2 Apr 2020 15:03:27 -0400
Subject: [PATCH] gnu: Add emacs-magit-annex.

* gnu/packages/emacs-xyz.scm (emacs-magit-annex): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a0275cbe18..b4c12f57ea 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -475,6 +475,31 @@  these arguments.  The prototypical use is for the command to call an external
 process, passing on the arguments as command line arguments.")
     (license license:gpl3+)))
 
+(define-public emacs-magit-annex
+  (let ((commit "ef5dce6267e9118a5eca82a22bcad0b67826c23a")
+        (revision "1"))
+    (package
+      (name "emacs-magit-annex")
+      (version (git-version "1.7.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/magit/magit-annex.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0vzkydgl889cq173zjl89g2vrddb9abc4a8gljiz3b4a7n5b1nrd"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("magit" ,emacs-magit)
+         ("transient" ,emacs-transient)))
+      (home-page "https://github.com/magit/magit-annex/")
+      (synopsis "Git-annex support for Magit")
+      (description
+       "Magit-annex adds a few git-annex operations to the Magit interface.")
+      (license license:gpl3+))))
+
 (define-public emacs-minions
   (package
     (name "emacs-minions")
-- 
2.26.0