diff mbox series

[bug#41227] gnu: Add python-random-user-agent.

Message ID 87mu6cgtkj.fsf@alice.lan
State Accepted
Headers show
Series [bug#41227] gnu: Add python-random-user-agent. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Edouard Klein May 13, 2020, 7:52 a.m. UTC
* gnu/packages/python-web.scm (python-random-user-agent): New variable.
---
 gnu/packages/python-web.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Marius Bakke May 20, 2020, 9:35 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/python-web.scm (python-random-user-agent): New variable.

Thanks!

A few cosmetic comments:

> +    (home-page
> +     "https://github.com/Luqman-Ud-Din/random_user_agent")

This line break is unnecessary.

> +    (synopsis
> +     "Random user agents based on filters provided by the user")

I shortened this to "List of user agents".

> +    (description
> +     "Provides list of user agents, from a collection of more than
> + 326,000 user agents, based on filters.")

And expanded on this a bit, to turn it into a full sentence and provide
a little more context.

Applied!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32a4d2b756..c6d8c3744b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3769,3 +3769,24 @@  Selenium specifically provides infrastructure for the W3C WebDriver specificatio
 — a platform and language-neutral coding interface compatible with all
 major web browsers.")
     (license license:asl2.0)))
+
+(define-public python-random-user-agent
+  (package
+    (name "python-random-user-agent")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "random_user_agent" version))
+       (sha256
+        (base32
+         "04nhzdh2ki7ybhjrmghxci6hcm6i03vvin2q2ynj87fbr1pa534g"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/Luqman-Ud-Din/random_user_agent")
+    (synopsis
+     "Random user agents based on filters provided by the user")
+    (description
+     "Provides list of user agents, from a collection of more than
+ 326,000 user agents, based on filters.")
+    (license license:expat)))