diff mbox series

[bug#42608] fixup!

Message ID 87mu3dnomi.fsf@gmx.com
State Accepted
Headers show
Series [bug#42608] fixup! | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Langlois Aug. 2, 2020, 1:50 p.m. UTC
Pierre Langlois writes:

> Hi Oleg, thanks for taking a look!
>
> Oleg Pykhalov writes:
>
>> Hi,
>>
>> Could you take a look on running the test-suite inside
>> emacsql-sqlite3-test.el file, please?
>
> Oh yes good idea! I hadn't noticed there were tests.
>
>
> See attached patch, I copied the test invocation from
> https://github.com/cireu/emacsql-sqlite3/blob/master/.github/workflows/main.yml#L40.
> I've also removed the ".git" from the origin url, to make 'guix lint'
> happy.

Whoops, I forgot to run the indent-code.el script, see new patch which
adds a couple of adjustments. I really need to setup emacs properly for
scheme... :-)

Comments

Oleg Pykhalov Aug. 2, 2020, 3:04 p.m. UTC | #1
OK, also I deleted .git from https://github.com/org-roam/org-roam.git
because of guix lint reports a HTTP redirect.

Pushed to master.

Thanks,
Oleg.
diff mbox series

Patch

From ccf27c4094fca5bed2ce29e5e129b8a4d86f2dec Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Thu, 30 Jul 2020 00:20:43 +0100
Subject: [PATCH] gnu: Add emacs-emacsql-sqlite3.

* gnu/packages/emacs-xyz.scm (emacs-emacsql-sqlite3): New variable.
---
 gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a90d789d7a..b8807528e0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13572,6 +13572,45 @@  has no concept of @code{TEXT} values; it's all just Lisp objects.  The Lisp
 object @code{nil} corresponds 1:1 with @code{NULL} in the database.")
     (license license:gpl3+)))

+(define-public emacs-emacsql-sqlite3
+  (package
+    (name "emacs-emacsql-sqlite3")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cireu/emacsql-sqlite3")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1yy9y27rckm776jnl2rh1fz3bh09690xwzq7102vlw7xkb9s7jhj"))))
+    (build-system emacs-build-system)
+    (native-inputs
+     `(("ert-runner" ,emacs-ert-runner)))
+    (inputs
+     `(("sqlite" ,sqlite)))
+    (propagated-inputs
+     `(("emacs-emacsql" ,emacs-emacsql)))
+    (arguments
+     `(#:tests? #t
+       #:test-command '("emacs" "-Q" "--batch" "-L" "."
+                        "--load" "emacsql-sqlite3-test.el"
+                        "-f" "ert-run-tests-batch-and-exit")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'embed-path-to-sqlite3
+           (lambda _
+             (substitute* "emacsql-sqlite3.el"
+               (("\\(executable-find \"sqlite3\"\\)")
+                (string-append "\"" (which "sqlite3") "\"")))
+             #t)))))
+    (home-page "https://github.com/cireu/emacsql-sqlite3")
+    (synopsis "EmacSQL backend for SQLite")
+    (description "This is yet another EmacSQL backend for SQLite which uses
+official @command{sqlite3} executable to access SQL database.")
+    (license license:gpl3+)))
+
 (define-public emacs-closql
   ;; Take a commit newer than 1.0.0 release because of Emacs upgrade to 26.3.
   (let ((commit "70b98dbae53611d10a461d9b4a6f71086910dcef"))
--
2.28.0