diff mbox series

[bug#42695] sway bump to 1.5

Message ID 87mu3cuhcn.fsf@gmail.com
State Accepted
Headers show
Series [bug#42695] sway bump to 1.5 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

André A. Gomes Aug. 3, 2020, 10:57 a.m. UTC

Comments

Oleg Pykhalov Aug. 3, 2020, 7:16 p.m. UTC | #1
Hi,

andremegafone@gmail.com (André Alexandre Gomes) writes:

> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index bc3c152627..04d76a7da9 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -1357,7 +1357,7 @@ modules for building a Wayland compositor.")
>  (define-public sway
>    (package
>      (name "sway")
> -    (version "1.4")
> +    (version "1.5")

Cannot build this version on a Guix master:
--8<---------------cut here---------------start------------->8---
Subproject  subprojects/wlroots is buildable: NO (disabling)
Dependency wlroots found: NO found 0.10.1 but need: '>=0.11.0' ; matched: '<0.12.0'
Run-time dependency wlroots found: NO

meson.build:75:1: ERROR: Invalid version of dependency, need 'wlroots' ['>=0.11.0'] found '0.10.1'.

A full log can be found at /tmp/guix-build-sway-1.5.drv-0/build/meson-logs/meson-log.txt
--8<---------------cut here---------------end--------------->8---

could you take a look on this, please?

[…]

Also, make sure your commit message follows project standarts for
patches https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

Thanks,
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index bc3c152627..04d76a7da9 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1357,7 +1357,7 @@  modules for building a Wayland compositor.")
 (define-public sway
   (package
     (name "sway")
-    (version "1.4")
+    (version "1.5")
     (source
      (origin
        (method git-fetch)
@@ -1366,7 +1366,7 @@  modules for building a Wayland compositor.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "11qf89y3q92g696a6f4d23qb44gqixg6qxq740vwv2jw59ms34ja"))))
+        (base32 "0r3b7h778l9i20z3him9i2qsaynpn9y78hzfgv3cqi8fyry2c4f9"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases