diff mbox series

[bug#47938] gnu: sway: Update to 1.6.

Message ID 87mttqslo4.fsf@posteo.net
State Accepted
Headers show
Series [bug#47938] gnu: sway: Update to 1.6. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev April 22, 2021, 9:39 a.m. UTC
Add argument #:meson ,meson-next to build correctly.
---
 gnu/packages/wm.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Jack Hill May 12, 2021, 11:29 p.m. UTC | #1
Thanks for preparing these patches. Sway and wlroots were already upgraded 
on the core-updates branch in afd2d66f2a4a7e4e7157f0a785491295434964c8 and 
b7daa450d93438e9c01fd72f930880e8d055921a. The new wlroots requires a new 
Wayland, which can only be updated on core updates because, according to 
`guix refresh -l wayland` 2474 would need to be rebuilt.

When the core-updates branch is merged, the new Sway and wlroots will 
become available. I don't know the timeline for that, but hopefully it 
won't be too long.

Therefore, I'm going to close this ticket. Thanks again for preparing it. 
For feedback on the patches, they looked good to me. Ordinarily, I would 
have tried to build them when reviewing as well, but I didn't in this case 
because of the Wayland dependency issue.

Best,
Jack
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a694913ca8..7f4af88721 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1440,7 +1440,7 @@  modules for building a Wayland compositor.")
 (define-public sway
   (package
     (name "sway")
-    (version "1.5.1")
+    (version "1.6")
     (source
      (origin
        (method git-fetch)
@@ -1449,10 +1449,11 @@  modules for building a Wayland compositor.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1xsa3h8zhf29p0mi90baxpr76jkd9pd1gr97ky8cnjbcs4isj9j0"))))
+        (base32 "0vnplva11yafhbijrk68wy7pw0psn9jm0caaymswq1s951xsn1c8"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
+     `(#:meson ,meson-next
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'hardcode-paths
            (lambda* (#:key inputs #:allow-other-keys)