diff mbox series

bug#50254: [PATCH] gnu: Add go-github-com-DHowett-go-plist.

Message ID 87mto2npgs.fsf@gnu.org
State Accepted
Headers show
Series bug#50254: [PATCH] gnu: Add go-github-com-DHowett-go-plist. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Sept. 24, 2021, 12:10 p.m. UTC
Hi,

Adam Kandur <rndd@tuta.io> skribis:

>>From 71fa733ace1ebf2186c15b0e17798fb7f72e385e Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Sun, 29 Aug 2021 19:52:55 +0300
> Subject: [PATCH] gnu: Add go-github-com-DHowett-go-plist.
>
> * gnu/packages/golang.scm (go-github-com-DHowett-go-plist): New variable.

Applied (finally!) with the cosmetic changes below.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 55a78c1a8b..a96f743f68 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1191,11 +1191,11 @@  standardized in RFC 7539.")
     (description "Set is the set collection for the Go language.")
     (license license:expat)))
 
-(define-public go-github-com-DHowett-go-plist
+(define-public go-github-com-dhowett-go-plist
   (let ((commit "1454fab16a0642638feb0ae98c41f79eccb2a20a")
         (revision "1"))
     (package
-      (name "go-github-com-DHowett-go-plist")
+      (name "go-github-com-dhowett-go-plist")
       (version (git-version "0.0.0" revision commit))
       (source (origin
                 (method git-fetch)
@@ -1207,16 +1207,17 @@  standardized in RFC 7539.")
                  (base32
                   "01c9wmhny2rxywcjipq1xa0xw4qm7yd001239grwxcja3b4n45v8"))))
       (build-system go-build-system)
-      (arguments
-       `(#:import-path "howett.net/plist"))
+      (arguments `(#:import-path "howett.net/plist"))
       (inputs
        `(("go-github.com-jessevdk-go-flags" ,go-github.com-jessevdk-go-flags)
          ("go-github-com-kr-pretty" ,go-github-com-kr-pretty)
          ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)
          ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
       (home-page "https://github.com/DHowett/go-plist")
-      (synopsis "A pure Go Apple Property List transcoder")
-      (description "This list transcoder supports encoding/decoding property lists (Apple XML, Apple Binary, OpenStep and GNUStep) from/to arbitrary Go types.")
+      (synopsis "Apple property list transcoder")
+      (description "This list transcoder supports encoding/decoding property
+lists (Apple XML, Apple Binary, OpenStep, and GNUStep) from/to arbitrary Go
+types.")
       (license license:giftware))))
 
 (define-public go-github-com-blanu-dust