diff mbox series

bug#51996: [PATCH] gnu: Add xfoil.

Message ID 87mtkxohtb.fsf_-_@gnu.org
State Accepted
Headers show
Series bug#51996: [PATCH] gnu: Add xfoil. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Dec. 18, 2021, 7:04 p.m. UTC
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

> * gnu/packages/engineering.scm (xfoil): New variable.

Applied with the changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 42f5544a54..e0fe0f354f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2961,6 +2961,10 @@  (define-public xfoil
              (with-directory-excursion "orrs"
                (invoke "bin/osgen" "osmaps_ns.lst"))
              (invoke "make" "-C" "plotlib")
+             (substitute* "bin/Makefile_gfortran"
+               (("^FFLAGS =(.*)$" _ suffix)
+                (string-append "FFLAGS = -fallow-argument-mismatch "
+                               suffix "\n")))
              (invoke "make" "-C" "bin" "-f" "Makefile_gfortran")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
@@ -2976,9 +2980,9 @@  (define-public xfoil
                (install-file "xfoil_doc.txt" doc-dir)))))
        #:tests? #f))
     (inputs
-     `(("libx11" ,libx11)))
+     (list libx11))
     (native-inputs
-     `(("gfortran" ,gfortran)))
+     (list gfortran))
     (home-page "https://web.mit.edu/drela/Public/web/xfoil/")
     (synopsis "Program for the design and analysis of subsonic airfoils")
     (description