@@ -2961,6 +2961,10 @@ (define-public xfoil
(with-directory-excursion "orrs"
(invoke "bin/osgen" "osmaps_ns.lst"))
(invoke "make" "-C" "plotlib")
+ (substitute* "bin/Makefile_gfortran"
+ (("^FFLAGS =(.*)$" _ suffix)
+ (string-append "FFLAGS = -fallow-argument-mismatch "
+ suffix "\n")))
(invoke "make" "-C" "bin" "-f" "Makefile_gfortran")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
@@ -2976,9 +2980,9 @@ (define-public xfoil
(install-file "xfoil_doc.txt" doc-dir)))))
#:tests? #f))
(inputs
- `(("libx11" ,libx11)))
+ (list libx11))
(native-inputs
- `(("gfortran" ,gfortran)))
+ (list gfortran))
(home-page "https://web.mit.edu/drela/Public/web/xfoil/")
(synopsis "Program for the design and analysis of subsonic airfoils")
(description
Hi, Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis: > * gnu/packages/engineering.scm (xfoil): New variable. Applied with the changes below. Thanks! Ludo’.