diff mbox series

[bug#54078] gnu: add libaml, libneatvnc, and wayvnc

Message ID 87mtilb40o.fsf@disroot.org
State New
Headers show
Series [bug#54078] gnu: add libaml, libneatvnc, and wayvnc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

kitzman Feb. 20, 2022, 9:51 p.m. UTC
I have attached a patch for the following packages:
  - gnu/packages/linux.scm:8818 libaml
  - gnu/packages/vnc.scm:361 libneatvnc
  - gnu/packages/vnc.scm:384 wayvnc

The libraries/software are created by a single person, with
dependents/dependencies which are also created by them. I can
split this into a patch set if deemed more appropriate.

Comments

Z572 July 30, 2024, 9:58 a.m. UTC | #1
kitzman via Guix-patches via <guix-patches@gnu.org> writes:

> I have attached a patch for the following packages:
>   - gnu/packages/linux.scm:8818 libaml
>   - gnu/packages/vnc.scm:361 libneatvnc
>   - gnu/packages/vnc.scm:384 wayvnc
>
> The libraries/software are created by a single person, with
> dependents/dependencies which are also created by them. I can
> split this into a patch set if deemed more appropriate.
>
> [2. patch for libaml, libneatvnc, and wayvnc --- text/x-diff; 0001-gnu-add-libaml-libneatvnc-and-wayvnc.patch]...

hello, i adjust your patch and pushed.

LIBAML rename to AML
LIBNEATVNC rename to NEATVNC.
Use the correct file-name
Move AML definition to gnu/packages/c.scm
Update to latest version
Fix WAYVNC cross-compiling.
Adjust WAYVNC's description.
diff mbox series

Patch

From 2d83057da80a6ee9617aa914497f7c58398a4fe1 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Sun, 20 Feb 2022 23:46:43 +0200
Subject: [PATCH] gnu: add libaml, libneatvnc, and wayvnc

---
 gnu/packages/linux.scm | 21 +++++++++++++++++++
 gnu/packages/vnc.scm   | 46 ++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 67 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c514c3cec..a2cd5bb1a2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8814,3 +8814,24 @@  (define-public libgpiod
     (license (list license:lgpl2.1+   ;; libgpiod
                    license:gpl2+      ;; gpio-tools
                    license:lgpl3+)))) ;; C++ bindings
+
+(define-public libaml
+  (package
+    (name "libaml")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/aml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "aml" (string-append "v" version)))
+              (sha256
+               (base32
+                "0mxmzlhiv88hm4sf8kyawyrml8qy1xis019hdyb5skl9g95z9yyf"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://github.com/any1/aml")
+    (synopsis "Another/Andri's Main Loop")
+    (description "Portable and simple main loop implementation.")
+    (license license:isc)))
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index c0fabe848b..5d2891c9ce 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -357,3 +357,49 @@  (define-public libvnc
 easily implement VNC server or client functionality in your program.")
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
+
+(define-public libneatvnc
+  (package
+    (name "libneatvnc")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/neatvnc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "neatvnc" (string-append "v" version)))
+              (sha256
+               (base32
+                "1wpq1vyjqra877vwc3n4i0c1dyhmabyn993cslf1k142ikyc0a8w"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config libdrm))
+    (propagated-inputs
+     (list libglvnd libxkbcommon pixman libaml gnutls libjpeg-turbo zlib))
+    (home-page "https://github.com/any1/neatvnc")
+    (synopsis "VNC server library that's intended to be fast and neat")
+    (description "This is a liberally licensed VNC server library that's intended to be fast and neat.")
+    (license license:isc)))
+
+(define-public wayvnc
+  (package
+    (name "wayvnc")
+    (version "0.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/wayvnc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "wayvnc" (string-append "v" version)))
+              (sha256
+               (base32
+                "0cws9jfnmxqycmlyllvvqzw4jsbrwwk10v9gy8wifv3c61rwgdkk"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config libaml libdrm scdoc))
+    (inputs
+     (list pixman libglvnd libxkbcommon libaml libneatvnc wayland))
+    (home-page "https://github.com/any1/wayvnc")
+    (synopsis "VNC server for wlroots-based Wayland compositors")
+    (description "This is a VNC server for wlroots-based Wayland compositors (no_entry Gnome and KDE are not supported). It attaches to a running Wayland session, creates virtual input devices, and exposes a single display via the RFB protocol. The Wayland session may be a headless one, so it is also possible to run wayvnc without a physical display attached.")
+    (license license:isc)))
-- 
2.32.0