diff mbox series

[bug#61057,2/3] gnu: flashrom: Use G-Expressions.

Message ID 87mt663jlg.wl-hako@ultrarare.space
State New
Headers show
Series gnu: flashrom: Update to 1.2.1. | expand

Commit Message

Hilton Chain Jan. 25, 2023, 12:05 p.m. UTC
* gnu/packages/flashing-tools.scm (flashrom): Use G-Expressions.
---
 gnu/packages/flashing-tools.scm | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index de4b477be8..7016d04092 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -29,6 +29,7 @@ 
 (define-module (gnu packages flashing-tools)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix utils)
@@ -71,14 +72,14 @@  (define-public flashrom
     (inputs (list dmidecode pciutils libusb libftdi))
     (native-inputs (list pkg-config))
     (arguments
-     '(#:make-flags
-       (list "CC=gcc"
-             (string-append "PREFIX=" %output)
-             "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
-       #:tests? #f                      ; no 'check' target
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))         ; no configure script
+     (list #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "PREFIX=" #$output)
+                   "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
+           #:tests? #f                  ; no 'check' target
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))   ; no configure script
     (home-page "https://flashrom.org/")
     (synopsis "Identify, read, write, erase, and verify ROM/flash chips")
     (description