diff mbox series

[bug#62600] gnu: emacs-slime: Add missing propagated input.

Message ID 87mt3rw4uj.fsf@protonmail.com
State New
Headers show
Series [bug#62600] gnu: emacs-slime: Add missing propagated input. | expand

Commit Message

John Kehayias April 1, 2023, 11:38 p.m. UTC
Slime is failing to load in emacs (confirmation from another user on IRC too) with "Cannot open load file: No such file or directory, ../lib/macrostep" Not sure when this started happening, must have been in the last month or few weeks?

This patch adds the missing propagated-input, confirming it runs after that (assuming you have sbcl of course).

I'll check the QA status later and can push after some time (what's the latest on this policy?) but I'm not anticipating any issues.

Thanks!
John

Comments

John Kehayias April 2, 2023, 1:05 a.m. UTC | #1
Checked rebuilds locally and pushed as f0c8cb44a4d912263025616bc921c011fcb1f0b4
diff mbox series

Patch

From 798e46d710bd44f1954054ea02b6400c232861e2 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sat, 1 Apr 2023 19:29:45 -0400
Subject: [PATCH] gnu: emacs-slime: Add missing propagated input.

Fixes error "Cannot open load file: No such file or directory,
../lib/macrostep" when trying to run slime.

* gnu/packages/emacs-xyz.scm (emacs-slime)[propagated-inputs]: Add
emacs-macrostep.
---
 gnu/packages/emacs-xyz.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index de4a7f301a..b11fbaf7b7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9219,6 +9219,8 @@  (define-public emacs-slime
                             (delete-file f))
                           doc-files)
                 (delete-file-recursively "doc")))))))
+    (propagated-inputs
+     (list emacs-macrostep))
     (native-inputs
      (list texinfo))
     (home-page "https://github.com/slime/slime")
-- 
2.39.2