diff mbox series

[bug#63409] Subject: [PATCH] gnu: Add labwc.

Message ID 87mt2cyk1h.fsf@163.com
State New
Headers show
Series [bug#63409] Subject: [PATCH] gnu: Add labwc. | expand

Commit Message

Feng Shu May 10, 2023, 2:52 a.m. UTC
From aba920372c247046088a34bdd20b514ba8706786 Mon Sep 17 00:00:00 2001
Date: Wed, 10 May 2023 10:38:48 +0800

* gnu/packages/wm.scm (labwc): New variable.
---
 gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 28e4c04814..954f0d3971 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -112,6 +112,7 @@ 
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages gettext)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gperf)
@@ -2808,6 +2809,48 @@  for wayland conceptually based on the X11 window manager
 read and write, and compatible with JSON.")
     (license license:bsd-2)))
 
+(define-public labwc
+  (package
+    (name "labwc")
+    (version "0.6.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/labwc/labwc")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1zbgj8r8ppvqnz2imh6f825f2lvsqpiqfa0r5g5r4nsvadiipivp"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config gettext-minimal))
+    (inputs
+     (list cairo
+           glib
+           libxcb
+           libxml2
+           pango
+           scdoc
+           wlroots))
+    (home-page "https://labwc.github.io")
+    (synopsis "Labwc is a wlroots-based window-stacking compositor for wayland")
+    (description
+     "Labwc is light-weight and independent with a focus on simply stacking
+windows well and rendering some window decorations, it is inspired by openbox.
+It takes a no-bling/frills approach and says no to features such as icons
+(except window buttons), animations, decorative gradients and any other
+options not required to reasonably render common themes.  It relies on clients
+for panels, screenshots, wallpapers and so on to create a full desktop
+environment.
+
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+
+Labwc has no reliance on any particular Desktop Environment, Desktop Shell or
+session.  Nor does it depend on any UI toolkits such as Qt or GTK.")
+    (license license:gpl2)))
+
 (define-public hikari
   (package
     (name "hikari")