diff mbox series

[bug#68617] gnu: Add go-github-com-gabriel-vasile-mimetype.

Message ID 87msszev23.fsf@gmail.com
State New
Headers show
Series [bug#68617] gnu: Add go-github-com-gabriel-vasile-mimetype. | expand

Commit Message

Artyom V. Poptsov Jan. 20, 2024, 6:09 p.m. UTC
Hello,

this patch adds "go-github-com-gabriel-vasile-mimetype"[1]
Thanks,
- avp

References:
1. https://github.com/gabriel-vasile/mimetype/

Comments

Sharlatan Hellseher Feb. 3, 2024, 5:42 a.m. UTC | #1
Hi,

Thank you for the patch!

> +          (add-before 'check 'add-supported-mimes-md
> +            (lambda* (#:key inputs #:allow-other-keys #:rest args)
> +              ;; This file needs to be available for writing during the
Instead of path string you may use import-path (change inputs in
lambda to use it. Check for examples in golang.scm.

> +              ;; tests otherwise they will fail.
> +              (let ((file
> +                     "src/
github.com/gabriel-vasile/mimetype/supported_mimes.md"))
It would be something like this (invoke "touch" (string-append import-path
"supported_mimes.md"). Or check if the code
 depends on HOME envar.

>+    (description
> +     "A fast Golang library for media type and file extension detection,
based on
> +magic numbers .")
Trailing space in the end of the sentence. Try to add more detail,
I've checked github page there is a link to a little bit detailed doc.

Apply common steps: guix lint, guix style.

Looking forward for v2.

Thanks,
Oleg
Sharlatan Hellseher Feb. 5, 2024, 3:51 p.m. UTC | #2
Hi,

 Modification applied
 - package placed in golang-xyz.scm, as golang.scm in a process of split into logical modules,
   see <https://lists.gnu.org/archive/html/guix-devel/2024-01/msg00113.html>
 - [description]: Append "This package provides a"

Pushed as 317d9840d371469daa23d13ac7c62477ed347b54 to master.

Thanks,
Oleg
diff mbox series

Patch

From 140d517610c3e9be4c5fb74e354f411c51d25cdc Mon Sep 17 00:00:00 2001
Message-ID: <140d517610c3e9be4c5fb74e354f411c51d25cdc.1705774054.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 20 Jan 2024 21:07:27 +0300
Subject: [PATCH] gnu: Add go-github-com-gabriel-vasile-mimetype.

* gnu/packages/golang.scm (go-github-com-gabriel-vasile-mimetype): New
  variable.

Change-Id: Icb1624eb9a890b6f711dacf5ff80f15b041f3b7d
---
 gnu/packages/golang.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8fea581248..c2154ca675 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4410,6 +4410,42 @@  (define-public go-github-com-technoweenie-multipartstreamer
 without reading the entire content into memory.")
     (license license:expat)))
 
+(define-public go-github-com-gabriel-vasile-mimetype
+  (package
+    (name "go-github-com-gabriel-vasile-mimetype")
+    (version "1.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gabriel-vasile/mimetype")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11swnjczhrza0xi8q2wlk056nnbcghm44vqs52zfv6rwqvy6imhj"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.20
+      #:import-path "github.com/gabriel-vasile/mimetype"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'add-supported-mimes-md
+            (lambda* (#:key inputs #:allow-other-keys #:rest args)
+              ;; This file needs to be available for writing during the
+              ;; tests otherwise they will fail.
+              (let ((file
+                     "src/github.com/gabriel-vasile/mimetype/supported_mimes.md"))
+                (invoke "touch" file)
+                (chmod file #o644)))))))
+    (propagated-inputs (list go-golang-org-x-net))
+    (home-page "https://github.com/gabriel-vasile/mimetype")
+    (synopsis "Golang library for media type and file extension detection")
+    (description
+     "A fast Golang library for media type and file extension detection, based on
+magic numbers .")
+    (license license:expat)))
+
 (define-public go-github-com-tevino-abool
   (let ((commit
           "3c25f2fe7cd0ef3eabefce1d90efd69a65d35b12")

base-commit: 9c367ee1967b213b507a8bf041ea6c2623ceea96
-- 
2.41.0