diff mbox series

bug#71219: [PATCH v5] gnu: llama-cpp: Update commit and configure flags for shared library build.

Message ID 87msmp7407.fsf@gnu.org
State New
Headers show
Series bug#71219: [PATCH v5] gnu: llama-cpp: Update commit and configure flags for shared library build. | expand

Commit Message

Ludovic Courtès July 10, 2024, 1:47 p.m. UTC
Hi Andy,

Andy Tai <atai@atai.org> skribis:

> * gnu/packages/machine-learning.scm (lama-cpp): Update to commit a5735e with
>   pkg-config support.
>   [arguments](configure-flags): Add cmake configure flag
>   for shared library build and adjust arguments to make openblas
>   found by cmake.
>   (phases) 'install-python-scripts: Remove references to deleted scripts
>   and add new ones upsteeam.
>
> Change-Id: I7c4bc219a22aa9a949e811b340c7cf745b176d14

Applied with the indentation changes shown below.  Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a2be0bf9c8..1cb6586e81 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -567,18 +567,22 @@  (define-public llama-cpp
       (arguments
        (list
         #:configure-flags
-        #~(list               "-DBUILD_SHARED_LIBS=ON"
-                              "-DLLAMA_BLAS=ON"
-                              "-DLLAMA_BLAS_VENDOR=OpenBLAS"
-                              (string-append "-DBLAS_INCLUDE_DIRS=" #$(this-package-input "openblas") "/include")
-                              (string-append "-DBLAS_LIBRARIES=" #$(this-package-input "openblas") "/lib/libopenblas.so")
+        #~(list "-DBUILD_SHARED_LIBS=ON"
+                "-DLLAMA_BLAS=ON"
+                "-DLLAMA_BLAS_VENDOR=OpenBLAS"
+                (string-append "-DBLAS_INCLUDE_DIRS="
+                               #$(this-package-input "openblas")
+                               "/include")
+                (string-append "-DBLAS_LIBRARIES="
+                               #$(this-package-input "openblas")
+                               "/lib/libopenblas.so")
 
-                              "-DLLAMA_NATIVE=OFF" ;no '-march=native'
-                              "-DLLAMA_FMA=OFF"    ;and no '-mfma', etc.
-                              "-DLLAMA_AVX2=OFF"
-                              "-DLLAMA_AVX512=OFF"
-                              "-DLLAMA_AVX512_VBMI=OFF"
-                              "-DLLAMA_AVX512_VNNI=OFF")
+                "-DLLAMA_NATIVE=OFF" ;no '-march=native'
+                "-DLLAMA_FMA=OFF"    ;and no '-mfma', etc.
+                "-DLLAMA_AVX2=OFF"
+                "-DLLAMA_AVX512=OFF"
+                "-DLLAMA_AVX512_VBMI=OFF"
+                "-DLLAMA_AVX512_VNNI=OFF")
 
         #:modules '((ice-9 textual-ports)
                     (guix build utils)