@@ -8043,6 +8043,42 @@ (define-public neural-amp-modeler-core
Modeler} plugins.")
(license license:expat)))
+(define-public neural-amp-modeler-lv2
+ (package
+ (name "neural-amp-modeler-lv2")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mikeoliphant/neural-amp-modeler-lv2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13i3sdp294ysfzpc78mfvqzd0hrdlj26kxh28yam0ahymc26v7g8"))
+ (modules '((guix build utils)))
+ (snippet #~(begin
+ (delete-file-recursively "deps/json")
+ (substitute* "src/CMakeLists.txt"
+ (("\\$\\{NAM_SOURCES\\}")
+ ""))))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no tests
+ (inputs (list eigen
+ lv2
+ neural-amp-modeler-core
+ nlohmann-json))
+ (home-page "https://github.com/mikeoliphant/neural-amp-modeler-lv2")
+ (synopsis "LV2 plugin for the Neural Amp Modeler")
+ (description
+ "This package provides an implementation of the @acronym{NAM, Neural Amp
+Modeler} models in an LV2 plugin. There is no user interface. Setting the
+model to use requires that your LV2 host supports @code{atom:Path}
+parameters.")
+ (license license:gpl3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar