bug#74242: [PATCH v1] gnu: Add python-vunit.
Commit Message
Hello,
Cayetano Santos <csantosb@inventati.org> skribis:
> * gnu/packages/fpga.scm (python-vunit): New variable.
>
> Change-Id: Ieb16ec16928e6b0b2af6992fd9566cb946990dad
Finally applied, with the changes below.
Thanks!
Ludo’.
@@ -537,12 +537,16 @@ (define-public python-vunit
(base32 "0s7j5bykbv34wgnxy5cl4zp6g0caidvzs8pd9yxjq341543xkjwm"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ;requires setuptools_scm >= 2.0.0, <3
+ '(#:tests? #f)) ;XXX: requires setuptools_scm >= 2.0.0, <3
(propagated-inputs (list python python-colorama))
(home-page "https://vunit.github.io")
- (synopsis "Open source unit testing framework for VHDL/SystemVerilog")
+ (synopsis "Unit testing framework for VHDL/SystemVerilog")
(description
- "VUnit features the functionality needed to realize continuous and automated testing of HDL code.")
+ "VUnit features the functionality needed to realize continuous and
+automated testing of HDL code.")
+
+ ;; According to 'LICENSE.rst', VUnit itself is under MPL but two
+ ;; subdirectories are under ASL.
(license (list license:mpl2.0 license:asl2.0))))
(define-public nvc