[bug#76571,02/15] gnu: python-beartype: Update to 0.19.0.

Message ID 87mse9whf1.fsf@ngraves.fr
State New
Headers
Series Some fixes |

Commit Message

Nicolas Graves Feb. 20, 2025, 3:49 p.m. UTC
  * gnu/packages/python-check.scm (python-beartype): Update to 0.19.0.
[arguments]: Remove former test-flags.
[native-inputs]: Remove python-setuptools, python-wheel. Add
python-hatchling, python-numpy and python-pygments.
---
 gnu/packages/python-check.scm | 16 ++++------------
 1 file changed, 4 insertions(+), 12 deletions(-)
  

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 582f16ec1d..34125475ad 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -341,24 +341,16 @@  (define-public python-pytest-freezer
 (define-public python-beartype
   (package
     (name "python-beartype")
-    (version "0.10.4")
+    (version "0.19.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "beartype" version))
        (sha256
-        (base32 "0amzckgw9c93bl4jf0q6322j9wyyf3i8vl03yixfkrpllzv6kv14"))))
+        (base32 "0wv598iv9c2s6ivfiara9pnkdlnas8xjw063wvyi0dswpb0xyhny"))))
     (build-system pyproject-build-system)
-    (arguments
-     (list
-      #:test-flags
-      #~(list
-         "beartype_test"
-         ;; These tests rely on git through the "get_main_readme_file" helper.
-         "-k" (string-append "not test_doc_readme "
-                             "and not test_sphinx "
-                             "and not test_pep561_mypy"))))
-    (native-inputs (list python-pytest python-setuptools python-wheel))
+    (native-inputs
+     (list python-hatchling python-numpy python-pygments python-pytest))
     (home-page "https://github.com/beartype/beartype")
     (synopsis "Fast runtime type checking for Python")
     (description "Beartype aims to be a very fast runtime type checking tool