[bug#34036] gnu: irssi: Update to 1.1.2 [fixes CVE-2019-5882].

Message ID 87lg3sdxvg.fsf@posteo.net
State Accepted
Commit c954fe6622660f1511ced2be955c35acfb8b124a
Headers show
Series [bug#34036] gnu: irssi: Update to 1.1.2 [fixes CVE-2019-5882]. | expand

Checks

Context Check Description
cbaines/package builds pending In Cuirass
cbaines/package builds pending In Cuirass
cbaines/applying patch fail Apply failed

Commit Message

Kei Kebreau Jan. 10, 2019, 9:08 p.m. UTC
Oh, it's not an auto-generated tarball! In that case I've attached the
much simpler update patch.

Leo Famulari <leo@famulari.name> writes:

> On Thu, Jan 10, 2019 at 01:03:20PM -0500, Kei Kebreau wrote:
>> * gnu/packages/irc.scm (irssi): Update to 1.1.2.
>> [source]: Use 'git-fetch'.
>> [arguments]: Add 'patch-scripts' phase.
>> [native-inputs]: Add autoconf, automake, and libtool.
>
> Thanks!
>
> But why switch to git-fetch when they offer a tarball? All else being
> equal, we should stick to tarballs when they are offered by upstream.
>
> Specifically, let's use this one:
>
> https://github.com/irssi/irssi/releases/download/1.1.2/irssi-1.1.2.tar.xz
From c954fe6622660f1511ced2be955c35acfb8b124a Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Thu, 10 Jan 2019 12:56:04 -0500
Subject: [PATCH] gnu: irssi: Update to 1.1.2 [fixes CVE-2019-5882].

* gnu/packages/irc.scm (irssi): Update to 1.1.2.
---
 gnu/packages/irc.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

Comments

Leo Famulari Jan. 10, 2019, 9:15 p.m. UTC | #1
On Thu, Jan 10, 2019 at 04:08:19PM -0500, Kei Kebreau wrote:
> Oh, it's not an auto-generated tarball! In that case I've attached the
> much simpler update patch.

Thanks :) Please push!

Patch

diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index ba31d36b9..ec1c4aae9 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -126,15 +126,15 @@  irssi, but graphical.")
 (define-public irssi
   (package
     (name "irssi")
-    (version "1.1.1")
+    (version "1.1.2")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/irssi/irssi/"
-                                 "releases/download/" version "/irssi-"
-                                 version ".tar.xz"))
-             (sha256
-              (base32
-               "1gx1flfh4a09nb3b5pvf0ygnbl7rry3l4gph8wij29dsl7khfj3q"))))
+              (method url-fetch)
+              (uri (string-append "https://github.com/irssi/irssi/"
+                                  "releases/download/" version "/irssi-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0clppwqhllrmqjg1dd47v9v1qiqx7cf9afm81bm1pscllf4jpk2w"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases