diff mbox series

bug#35855: [PATCH] gnu: Add coq-stdpp.

Message ID 87lfyvstxa.fsf@gnu.org
State Accepted
Headers show
Series bug#35855: [PATCH] gnu: Add coq-stdpp. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès May 24, 2019, 4:23 p.m. UTC
Hi Dan,

I took the liberty to apply the minor changes below and applied the
patch (grep, diffutils, etc. are implicit inputs of ‘gnu-build-system’,
so you don’t need to list them; as for ‘invoke’, it’s now the preferred
way to invoke programs.)

Thank you!

Ludo’.

Comments

Dan Frumin May 24, 2019, 5:11 p.m. UTC | #1
Hi Ludovic,

Thanks for looking over my patch!

On 24-05-19 18:23, Ludovic Courtès wrote:
> Hi Dan,
> 
> I took the liberty to apply the minor changes below and applied the
> patch (grep, diffutils, etc. are implicit inputs of ‘gnu-build-system’,
> so you don’t need to list them;

Oh interesting. I recall that I had to add those programs explicitly as inputs as some point (otherwise I couldn't build it in `guix environment 
coq-stdpp`), but perhaps my memory is playing tricks on me.

> as for ‘invoke’, it’s now the preferred
> way to invoke programs.)
>

Oops, dunno why I missed that...


> Thank you!
> 
> Ludo’.
> 
> 
> diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
> index 15a7e791f9..6c48af4fc9 100644
> --- a/gnu/packages/coq.scm
> +++ b/gnu/packages/coq.scm
> @@ -551,11 +551,6 @@ kernel.")
>                 (sha256
>                  (base32 "11m7kqxsbxygk41v2wsi3npdzwin9fcnzc1gn0gq0rd57wnqk83i"))))
>       (build-system gnu-build-system)
> -    (native-inputs
> -     `(("grep" ,grep)  ;; need egrep for tests
> -       ("gawk" ,gawk)
> -       ;; need diff for tests
> -       ("diffutils" ,diffutils)))
>       (inputs
>        `(("coq" ,coq)))
>       (arguments
> @@ -566,10 +561,10 @@ kernel.")
>            (replace 'install
>              (lambda* (#:key outputs #:allow-other-keys)
>                (setenv "COQLIB" (string-append (assoc-ref outputs "out") "/lib/coq/"))
> -             (zero? (system* "make"
> -                             (string-append "COQLIB=" (assoc-ref outputs "out")
> -                                            "/lib/coq/")
> -                             "install")))))))
> +             (invoke "make"
> +                     (string-append "COQLIB=" (assoc-ref outputs "out")
> +                                    "/lib/coq/")
> +                     "install"))))))
>       (description "This project contains an extended \"Standard Library\" for
>   Coq called coq-std++.  The key features are:
>   @itemize
>
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 15a7e791f9..6c48af4fc9 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -551,11 +551,6 @@  kernel.")
               (sha256
                (base32 "11m7kqxsbxygk41v2wsi3npdzwin9fcnzc1gn0gq0rd57wnqk83i"))))
     (build-system gnu-build-system)
-    (native-inputs
-     `(("grep" ,grep)  ;; need egrep for tests
-       ("gawk" ,gawk)
-       ;; need diff for tests
-       ("diffutils" ,diffutils)))
     (inputs
      `(("coq" ,coq)))
     (arguments
@@ -566,10 +561,10 @@  kernel.")
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (setenv "COQLIB" (string-append (assoc-ref outputs "out") "/lib/coq/"))
-             (zero? (system* "make"
-                             (string-append "COQLIB=" (assoc-ref outputs "out")
-                                            "/lib/coq/")
-                             "install")))))))
+             (invoke "make"
+                     (string-append "COQLIB=" (assoc-ref outputs "out")
+                                    "/lib/coq/")
+                     "install"))))))
     (description "This project contains an extended \"Standard Library\" for
 Coq called coq-std++.  The key features are:
 @itemize