diff mbox series

[bug#36073,2/5] gnu: sway: Update to 1.1.1.

Message ID 87lfyayyj8.fsf@riseup.net
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Meiyo Peng June 10, 2019, 2:17 a.m. UTC
Hi Stefan,

Thank you for your work on sway.

There is one minor issue.  In sway's release note:

#+begin_quote
  swaybg is now distributed as a standalone program which is compatible
  with many Wayland compositors. Unlike the other sway clients which have
  been split into separate projects, however, swaybg is a required
  dependency of sway. Packagers are encouraged to configure it as such
  when updating sway for their distribution.
#+end_quote

The author states that swaybg is now a standalone program but it should
be treated as a required dependency of sway.  So we should add swaybg
into sway's propagated-inputs.


--
Meiyo Peng
https://www.pengmeiyu.com/

Comments

Tobias Geerinckx-Rice June 10, 2019, 3:05 a.m. UTC | #1
Meiyo,

Meiyo Peng wrote:
> The author states that swaybg is now a standalone program but it 
> should
> be treated as a required dependency of sway.  So we should add 
> swaybg
> into sway's propagated-inputs.

I don't quite see the connection between these two sentences…  Why 
propagated?

Kind regards,

T G-R
diff mbox series

Patch

From 1d24d0ceb27050821208e5dca109dd073d9d0b58 Mon Sep 17 00:00:00 2001
From: Meiyo Peng <meiyo@riseup.net>
Date: Sun, 9 Jun 2019 16:15:50 +0800
Subject: [PATCH 1/2] gnu: sway: Propagate swaybg.

* gnu/packages/wm.scm (sway)[propagated-inputs]: Add swaybg.
---
 gnu/packages/wm.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f0589e98f1..089e083e8b 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
-;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
+;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@riseup.net>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
 ;;;
@@ -1223,6 +1223,7 @@  modules for building a Wayland compositor.")
                      ("pkg-config" ,pkg-config)
                      ("scdoc" ,scdoc)
                      ("wayland-protocols" ,wayland-protocols)))
+    (propagated-inputs `(("swaybg" ,swaybg)))
     (home-page "https://github.com/swaywm/sway")
     (synopsis "Wayland compositor compatible with i3")
     (description "Sway is a i3-compatible Wayland compositor.")
-- 
2.22.0