diff mbox series

[bug#39105,1/2] gnu: Add ghc-llvm-hs-pure

Message ID 87lfq84w7c.fsf@jo.zone
State Accepted
Headers show
Series [bug#39105,1/2] gnu: Add ghc-llvm-hs-pure | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

JoJo Jan. 15, 2020, 2:43 p.m. UTC
* gnu/packages/haskell-xyz.scm
(ghc-llvm-hs-pure): New variable.
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Leo Famulari Jan. 23, 2020, 9:43 p.m. UTC | #1
On Wed, Jan 15, 2020 at 03:43:03PM +0100, JoJo wrote:
> * gnu/packages/haskell-xyz.scm
> (ghc-llvm-hs-pure): New variable.

Thanks! I cleaned up both patches according to `guix lint` (mostly...)
and made a few other cosmetic changes, as well as some minor
clarifications to the synopses and descriptions.

Pushed as e3ee802379f33aa3fae0a40be33fe6a4f2ae34d2

Thanks again for the contribution!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3a9880f58c..a04e8f652e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6704,6 +6704,35 @@  ByteString, for types that support input and output, and for types that
 can handle infinite lists.")
     (license license:bsd-3)))
 
+(define-public ghc-llvm-hs-pure
+  (package
+    (name "ghc-llvm-hs-pure")
+    (version "9.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/llvm-hs-pure/llvm-hs-pure-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0pxb5ah8r5pzpz2ibqw3g9g1isigb4z7pbzfrwr8kmcjn74ab3kf"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-attoparsec" ,ghc-attoparsec)
+              ("ghc-fail" ,ghc-fail)
+              ("ghc-unordered-containers" ,ghc-unordered-containers)))
+    (native-inputs `(("ghc-tasty" ,ghc-tasty)
+                     ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+                     ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (home-page "http://github.com/llvm-hs/llvm-hs/")
+    (synopsis "Pure Haskell LLVM functionality (no FFI).")
+    (description "llvm-hs-pure is a set of pure Haskell types and functions
+for interacting with LLVM. It includes an ADT to represent LLVM IR. The
+llvm-hs package builds on this one with FFI bindings to LLVM, but llvm-hs-pure
+does not require LLVM to be available.")
+    (license license:bsd-3)))
+
 (define-public ghc-logging-facade
   (package
     (name "ghc-logging-facade")