diff mbox series

[bug#40340] etc: indent-code.el: Use the --quick option.

Message ID 87lfnhxhje.fsf@gmail.com
State Accepted
Headers show
Series [bug#40340] etc: indent-code.el: Use the --quick option. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Maxim Cournoyer March 31, 2020, 4:41 a.m. UTC
Hello!

I noticed two small annoyances with the indent-code.el script, which are
explained and fixed in the attached patch.

Comments

Simon Tournier May 13, 2020, 12:45 a.m. UTC | #1
Hi Maxim,

On Tue, 31 Mar 2020 at 06:42, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

> * configure.ac: Remove the warning about Emacs.  Emacs can now be installed
> any time by the user if they want to use the script.

The point of this warning was to inform (teach) the user if they does
not know how to use 'etc/indent-code.el'; basically newcomers which do
not use Emacs and do not read manual cover to cover.
Well, maybe it is not useful since the manual already explains [1] and
this message is meaningful by itself:

--8<---------------cut here---------------start------------->8---
./etc/indent-code.el gnu/packages/maths.scm
./etc/indent-code.el: line 1: exec: emacs: not found
--8<---------------cut here---------------end--------------->8---

[1] https://guix.gnu.org/manual/devel/en/guix.html#Formatting-Code


Thank you for the improvement.

All the best,
simon
Maxim Cournoyer May 15, 2020, 3:09 a.m. UTC | #2
Hello Simon,

zimoun <zimon.toutoune@gmail.com> writes:

> Hi Maxim,
>
> On Tue, 31 Mar 2020 at 06:42, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> * configure.ac: Remove the warning about Emacs.  Emacs can now be installed
>> any time by the user if they want to use the script.
>
> The point of this warning was to inform (teach) the user if they does
> not know how to use 'etc/indent-code.el'; basically newcomers which do
> not use Emacs and do not read manual cover to cover.
> Well, maybe it is not useful since the manual already explains [1] and
> this message is meaningful by itself:
>
> ./etc/indent-code.el gnu/packages/maths.scm
> ./etc/indent-code.el: line 1: exec: emacs: not found
>
> [1] https://guix.gnu.org/manual/devel/en/guix.html#Formatting-Code
>
>
> Thank you for the improvement.

The warning was indeed useful before this change, as the script was not
generated in the event Emacs was not found at configuration time.  Now
that the script is always available, it can be removed.

I went ahead and merged this as commit cb21ae7671.

Thank you for taking a look :-).

Maxim
diff mbox series

Patch

From ce30a6ceb76595ce0ba87eeb54f0b6624485354f Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 31 Mar 2020 00:12:01 -0400
Subject: [PATCH] etc: indent-code.el: Use the --quick option.

This prevents Emacs from loading the autoload definitions found in its
profile, which needlessly clutters the output.  It also prevents Geiser (if
installed) from blocking the script and asking the user to input the Scheme
implementation to use.

The trick for passing multiple arguments to Emacs is to use what is called a
"sesquicolon" (see https://www.emacswiki.org/emacs/EmacsScripts).

* etc/indent-code.el.in: Rename to...
* etc/indent-code.el: ...this.  Adapt the shebang to use a sesquicolon, and
pass the --quick option to Emacs.  Since this line is interpreted by the
shell, simply use Emacs from the PATH instead of from a hard coded location.
(main): New procedure, used as the entry point.
* configure.ac: Remove the warning about Emacs.  Emacs can now be installed
any time by the user if they want to use the script.
* .gitignore: No longer ignore changes to etc/indent-code.el.
---
 .gitignore                                |  1 -
 configure.ac                              |  9 ----
 etc/{indent-code.el.in => indent-code.el} | 52 ++++++++++++-----------
 3 files changed, 27 insertions(+), 35 deletions(-)
 rename etc/{indent-code.el.in => indent-code.el} (71%)

diff --git a/.gitignore b/.gitignore
index fd2cf56098..cc5ceb5e10 100644
--- a/.gitignore
+++ b/.gitignore
@@ -149,7 +149,6 @@  stamp-h[0-9]
 tmp
 /doc/os-config-lightweight-desktop.texi
 /nix/scripts/download
-/etc/indent-code.el
 /.version
 /doc/stamp-[0-9]
 /gnu/packages/bootstrap
diff --git a/configure.ac b/configure.ac
index 6a6a020585..5ed2cf7aa0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,15 +284,6 @@  dnl Documentation translation.
 AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
 AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
 
-dnl Emacs (optional), for 'etc/indent-code.el'.
-AC_PATH_PROG([EMACS], [emacs])
-if test "x$EMACS" = x; then
-    AC_MSG_WARN([Please install GNU Emacs to use etc/indent-code.el.])
-else
-    AC_SUBST([EMACS])
-    AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
-fi
-
 case "$storedir" in
   /gnu/store)
     ;;
diff --git a/etc/indent-code.el.in b/etc/indent-code.el
similarity index 71%
rename from etc/indent-code.el.in
rename to etc/indent-code.el
index 6102b5d1ab..255ffb126b 100755
--- a/etc/indent-code.el.in
+++ b/etc/indent-code.el
@@ -1,8 +1,9 @@ 
-#!@EMACS@ --script
+:;exec emacs --batch --quick --load="$0" --funcall=main "$@"
 ;;; indent-code.el --- Run Emacs to indent a package definition.
 
 ;; Copyright © 2017 Alex Kost <alezost@gmail.com>
 ;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 
 ;; This file is part of GNU Guix.
 
@@ -86,29 +87,30 @@ 
  (with-syntax 1))
 
 
-(pcase command-line-args-left
-  (`(,file-name ,package-name)
-   ;; Indent the definition of PACKAGE-NAME in FILE-NAME.
-   (find-file file-name)
-   (goto-char (point-min))
-   (if (re-search-forward (concat "^(define\\(-public\\) +"
-                                  package-name)
-                          nil t)
-       (let ((indent-tabs-mode nil))
-         (beginning-of-defun)
-         (indent-sexp)
-         (save-buffer)
-         (message "Done!"))
-     (error "Package '%s' not found in '%s'"
-            package-name file-name)))
-  (`(,file-name)
-   ;; Indent all of FILE-NAME.
-   (find-file file-name)
-   (let ((indent-tabs-mode nil))
-     (indent-region (point-min) (point-max))
-     (save-buffer)
-     (message "Done!")))
-  (x
-   (error "Usage: indent-code.el FILE [PACKAGE]")))
+(defun main ()
+  (pcase command-line-args-left
+    (`(,file-name ,package-name)
+     ;; Indent the definition of PACKAGE-NAME in FILE-NAME.
+     (find-file file-name)
+     (goto-char (point-min))
+     (if (re-search-forward (concat "^(define\\(-public\\) +"
+                                    package-name)
+                            nil t)
+         (let ((indent-tabs-mode nil))
+           (beginning-of-defun)
+           (indent-sexp)
+           (save-buffer)
+           (message "Done!"))
+       (error "Package '%s' not found in '%s'"
+              package-name file-name)))
+    (`(,file-name)
+     ;; Indent all of FILE-NAME.
+     (find-file file-name)
+     (let ((indent-tabs-mode nil))
+       (indent-region (point-min) (point-max))
+       (save-buffer)
+       (message "Done!")))
+    (x
+     (error "Usage: indent-code.el FILE [PACKAGE]"))))
 
 ;;; indent-code.el ends here
-- 
2.25.2