diff mbox series

[bug#40258] gnu: Add emacs-flycheck-elm.

Message ID 87lfnhv7v3.fsf@asu.edu
State Accepted
Headers show
Series [bug#40258] gnu: Add emacs-flycheck-elm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo March 30, 2020, 9:41 p.m. UTC
Hi Nicolas,

They fixed the license upstream already. Here I rebased on master and
changed inputs -> propagated inputs. Also I updated the commit to the
one with the correct license.

Thanks again,

John

Comments

Nicolas Goaziou March 30, 2020, 10:31 p.m. UTC | #1
John Soo <jsoo1@asu.edu> writes:

> They fixed the license upstream already. Here I rebased on master and
> changed inputs -> propagated inputs. Also I updated the commit to the
> one with the correct license.

Applied as 2330ef9427599315644bd316bb8169bd9f3d1664. I also moved
`build-system' part up in the package definition.

Thank you!
diff mbox series

Patch

From d1ff6af2826f0057a5e3c74b9dafcf91ea7b9524 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:57:31 -0700
Subject: [PATCH] gnu: Add emacs-flycheck-elm.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-elm): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 74136e7efa..f97c806aab 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22039,3 +22039,28 @@  conventions.")
       (description "Haskell-Snippets is a collection of YASnippet Haskell
 snippets for Emacs.")
       (license license:expat))))
+
+(define-public emacs-flycheck-elm
+  (let ((revision "0")
+        (commit "1b60050efd4729bfba548f3e5adbcb58436667cb"))
+   (package
+    (name "emacs-flycheck-elm")
+    (version (git-version "0" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/bsermons/flycheck-elm")
+         (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1kjms9d2c98ffd1qxs879qhg0n4jzic0r5kni9y4gz3v09ww8zms"))))
+    (propagated-inputs
+     `(("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-let-alist" ,emacs-let-alist)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/bsermons/flycheck-elm")
+    (synopsis "Flycheck support for the Elm")
+    (description "Flycheck-elm adds flycheck support for Elm.")
+    (license license:gpl3+))))
-- 
2.26.0