diff mbox series

[bug#40615] gnu: emacs-use-package: Make sure manual is built and installed

Message ID 87lfmy29gd.fsf@gmail.com
State Accepted
Headers show
Series [bug#40615] gnu: emacs-use-package: Make sure manual is built and installed | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Evan Straw April 14, 2020, 12:32 a.m. UTC
Hi all,
When trying to use use-package today I discovered that it has a Texinfo
manual, but this manual is not built or installed by the Guix
package. The patch below should remedy this.

-- Evan <evan.straw99@gmail.com>

Comments

Brett Gilio July 25, 2020, 2:05 a.m. UTC | #1
Hi Evan,

Thank you for the patch! Sorry it is so late getting to be reviewed. I
have made a few changes to the commit message and the sub-header. Pushed
to master with 30aa5dd7e7180d163d409b080bf89e8a15a5ba4d.

Brett Gilio
diff mbox series

Patch

From 62c94580a0d083a7ba703ed92d941c945bb90ae0 Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Mon, 13 Apr 2020 17:29:20 -0700
Subject: [PATCH] gnu: emacs-use-package: Make sure manual is built and
 installed.

* gnu/packages/emacs-xyz.scm (emacs-use-package): Make sure manual is built
  and installed.
---
 gnu/packages/emacs-xyz.scm | 17 ++++++++++++++++-
 1 file changed, 16 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd1ce3a298..ee20eb9053 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9563,13 +9563,28 @@  abbreviation of the mode line displays (lighters) of minor modes.")
                (base32
                 "1b7mjjh0d6fmkkd9vyj64vca27xqhga0nvyrrcqxpqjn62zq046y"))))
     (build-system emacs-build-system)
+    (native-inputs
+     `(("texinfo" ,texinfo)))
     (propagated-inputs
      `(("emacs-diminish" ,emacs-diminish)))
     (arguments
      `(#:tests? #t
        #:test-command '("emacs" "--batch"
                         "-l" "use-package-tests.el"
-                        "-f" "ert-run-tests-batch-and-exit")))
+                        "-f" "ert-run-tests-batch-and-exit")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'install-manual
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (info-dir (string-append out "/share/info")))
+               (mkdir-p info-dir)
+               (install-file "use-package.info" info-dir)
+               #t)))
+         (add-before 'install-manual 'build-manual
+           (lambda _
+             (invoke "makeinfo" "use-package.texi")
+             #t)))))
     (home-page "https://github.com/jwiegley/use-package")
     (synopsis "Declaration for simplifying your .emacs")
     (description "The use-package macro allows you to isolate package
-- 
2.20.1