diff mbox series

[bug#42525,2/2] gnu: Add emacs-major-mode-hydra.

Message ID 87lfj8gx9q.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#42525,1/2] gnu: Add emacs-pretty-hydra. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph July 25, 2020, 2:10 a.m. UTC
Patch file is attached.  Similar to the first patch in this 
series, `guix lint` reports "the source file name should contain 
the package name".

--
Joseph LaFreniere

Comments

Oleg Pykhalov July 25, 2020, 1:28 p.m. UTC | #1
Joseph LaFreniere <joseph@lafreniere.xyz> writes:

> Patch file is attached.  Similar to the first patch in this series, `guix
> lint` reports "the source file name should contain the package name".

Yes, because emacs-major-mode-hydra inherits emacs-pretty-hydra.


Does emacs-major-mode-hydra is useful without emacs-pretty-hydra and
vice versa?

I guess not, in that case we could just have emacs-pretty-hydra
containing '*.el' for both.

[…]

> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 147c6b476b..649f856a83 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -677,6 +677,20 @@ mode-specific key bindings.  It is intended for use as a library only; see
>  package @code{emacs-major-mode-hydra} for a user-friendly interface.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-major-mode-hydra
> +  (package
> +    ...
> +    (arguments
> +     `(#:include '("^major-mode-hydra\\.el$")))
> +    (synopsis "Create nice-looking hydras")

Could you extend the synopsis little bit? ;-)

Thanks,
Oleg.
diff mbox series

Patch

From 0e528063cdc3a768059cb0be5c8430506b756b6e Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sat, 18 Jul 2020 12:50:22 -0500
Subject: [PATCH 2/2] gnu: Add emacs-major-mode-hydra.

* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.
---
 gnu/packages/emacs-xyz.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 147c6b476b..649f856a83 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -677,6 +677,20 @@  mode-specific key bindings.  It is intended for use as a library only; see
 package @code{emacs-major-mode-hydra} for a user-friendly interface.")
     (license license:gpl3+)))
 
+(define-public emacs-major-mode-hydra
+  (package
+    (inherit emacs-pretty-hydra)
+    (name "emacs-major-mode-hydra")
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-pretty-hydra" ,emacs-pretty-hydra)))
+    (arguments
+     `(#:include '("^major-mode-hydra\\.el$")))
+    (synopsis "Create nice-looking hydras")
+    (description
+     "This package provides the macro @code{pretty-hydra-define} to define
+hydras with one column per group of heads.")))
+
 (define-public emacs-minions
   (package
     (name "emacs-minions")
-- 
2.27.0