diff mbox series

[bug#42549] gnu: Add emacs-standard-dirs.

Message ID 87lfj6s18t.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#42549] gnu: Add emacs-standard-dirs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph July 26, 2020, 4:13 p.m. UTC
Patch file is attached.  Disclaimer that I am the author of the 
upstream package.

Even though Guix does not (to the best of my knowledge) currently 
support macOS, I left the paragraph about behavior in macOS in the 
description because cross-platform support for users of multiple 
operating systems was one of my primary motivations for writing 
the package.

--
Joseph LaFreniere

Comments

Nicolas Goaziou July 28, 2020, 10:37 a.m. UTC | #1
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Patch file is attached.  Disclaimer that I am the author of the
> upstream package.

Thank you.

> Even though Guix does not (to the best of my knowledge) currently
> support macOS, I left the paragraph about behavior in macOS in the
> description because cross-platform support for users of multiple
> operating systems was one of my primary motivations for writing the
> package.

I suggest to eschew the problem and stick to the first sentence of the
description:

  This package provides platform-specific paths for reading and writing
  configuration, cache, and other data.

I think this is enough to understand what the package is about without
looking at the gory details.

WDYT?

Regards,
diff mbox series

Patch

From 2e0716d7ed9b35b780cbefda29bb9982079461ed Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Jul 2020 11:06:19 -0500
Subject: [PATCH] gnu: Add emacs-standard-dirs.

* gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable.
---
 gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index db395361b9..d9529a2182 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3570,6 +3570,39 @@  particular, the minor mode works quite well with Org or Markdown modes, or
 other markup language major modes.")
       (license license:gpl3+))))
 
+(define-public emacs-standard-dirs
+  (package
+    (name "emacs-standard-dirs")
+    (version "2.0.0")
+    (home-page "https://github.com/lafrenierejm/standard-dirs.el")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0r814qcrhvx4qlx4sdzwdmrhiryslqclx0bnpp0qcrbx6g8qfl25"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-f" ,emacs-f)
+       ("emacs-s" ,emacs-s)))
+    (synopsis "Platform-specific paths for config, cache, and other data")
+    (description
+     "This package provides platform-specific paths for reading and writing
+configuration, cache, and other data.
+
+On Linux (@code{gnu/linux}), the directory paths conform to the
+@uref{https://specifications.freedesktop.org/basedir-spec/basedir-spec-0.6.html,
+XDG Base Directory Specification} where relevant, with fallbacks to
+@code{xdg-user-dirs}.
+
+On macOS (@code{darwin}), the directory paths conform to Apple's
+@uref{https://developer.apple.com/library/archive/documentation/FileManagement/Conceptual/FileSystemProgrammingGuide/FileSystemOverview/FileSystemOverview.html#//apple_ref/doc/uid/TP40010672-CH2-SW14,
+macOS File System Programming Guide}.")
+    (license license:gpl3+)))
+
 (define-public emacs-string-inflection
   (package
     (name "emacs-string-inflection")
-- 
2.27.0