diff mbox series

[bug#43459] gnu: guile-wisp: Update to 1.0.3

Message ID 87lfh92xii.fsf@web.de
State Accepted
Headers show
Series [bug#43459] gnu: guile-wisp: Update to 1.0.3 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Dr. Arne Babenhauserheide Sept. 16, 2020, 9:59 p.m. UTC
From 06ca3245ff88bc51c0c7f929b02d0c9e22dc800d Mon Sep 17 00:00:00 2001

    * gnu/packages/guile-xyz.scm (guile-wisp): Update to 1.0.3
    [source]: Access via hg and change from bitbucket to hg.sr.ht
    [phases] call autoreconf before 'configure,
    [phases] remove Guile 3 patch because Guile 3 is supported in 1.0.3
    [native-inputs]: add autoconf and automake
---
 gnu/packages/guile-xyz.scm | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)

Comments

Ricardo Wurmus Sept. 17, 2020, 11:47 a.m. UTC | #1
Hi Arne,

> From 06ca3245ff88bc51c0c7f929b02d0c9e22dc800d Mon Sep 17 00:00:00 2001
>
>     * gnu/packages/guile-xyz.scm (guile-wisp): Update to 1.0.3
>     [source]: Access via hg and change from bitbucket to hg.sr.ht
>     [phases] call autoreconf before 'configure,
>     [phases] remove Guile 3 patch because Guile 3 is supported in 1.0.3
>     [native-inputs]: add autoconf and automake

I modified the commit message to better match our conventions and
replaced the existing 'bootstrap phase instead of adding a new phase
before 'configure (the effect is the same).

Pushed it to the “master” branch with commit 8b030edf02.

Thank you!
Dr. Arne Babenhauserheide Sept. 17, 2020, 10:55 p.m. UTC | #2
Hi Ricardo,

Ricardo Wurmus <rekado@elephly.net> writes:

> I modified the commit message to better match our conventions and
> replaced the existing 'bootstrap phase instead of adding a new phase
> before 'configure (the effect is the same).
>
> Pushed it to the “master” branch with commit 8b030edf02.
>
> Thank you!

Thank you! :-)

Best wishes,
Arne
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3090c6078b..2851766c3f 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1621,15 +1621,16 @@  The library is shipped with documentation in Info format and usage examples.")
 (define-public guile-wisp
   (package
     (name "guile-wisp")
-    (version "1.0.2")
+    (version "1.0.3")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://bitbucket.org/ArneBab/"
-                                  "wisp/downloads/wisp-"
-                                  version ".tar.gz"))
+              (method hg-fetch)
+              (uri (hg-reference
+                    (url "https://hg.sr.ht/~arnebab/wisp")
+                    (changeset (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "03pz7pj9jyallynhflp5s7qax8dj1fs8la434wrfgz7g1kgjnvf6"))))
+                "10g97jz3ahpb5mg933ajsc3pa9jxlg14f42yf01qwx0dwq1b06d5"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -1643,11 +1644,9 @@  The library is shipped with documentation in Info format and usage examples.")
                            (guix build emacs-utils))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'support-guile-3.0
+         (add-before 'configure 'autoreconf
            (lambda _
-             (substitute* "configure"
-               (("_guile_versions_to_search=\"2.2")
-                "_guile_versions_to_search=\"3.0 2.2"))
+             (invoke "autoreconf" "-vif")
              #t))
          (add-before 'configure 'patch-/usr/bin/env
            (lambda _
@@ -1689,7 +1688,9 @@  The library is shipped with documentation in Info format and usage examples.")
     (inputs
      `(("guile" ,guile-3.0)))
     (native-inputs
-     `(("emacs" ,emacs-minimal)
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("emacs" ,emacs-minimal)
        ("python" ,python)
        ("pkg-config" ,pkg-config)))
     (synopsis "Whitespace to lisp syntax for Guile")