diff mbox series

[bug#49284,v3] gnu: Add fheroes2

Message ID 87lf474dia.fsf@trop.in
State Accepted
Headers show
Series [bug#49284,v3] gnu: Add fheroes2 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Sept. 8, 2021, 9:34 a.m. UTC
Updated to 0.9.7.

Comments

Nicolas Goaziou Sept. 13, 2021, 8:25 p.m. UTC | #1
Hello,

Andrew Tropin <andrew@trop.in> writes:

> * gnu/packages/games.scm (fheroes2): New variable.

Applied. Thank you.

I slightly reworded description field so it would contain full
sentences.

Regards,
Andrew Tropin Sept. 14, 2021, 6:27 a.m. UTC | #2
On 2021-09-13 22:25, Nicolas Goaziou wrote:

> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> * gnu/packages/games.scm (fheroes2): New variable.
>
> Applied. Thank you.
>
> I slightly reworded description field so it would contain full
> sentences.
>

Thank you!)

> 
> Regards,
diff mbox series

Patch

From eca57a5dfb8327df9cc6dacee5db5d2693b43fa2 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Wed, 30 Jun 2021 13:17:21 +0300
Subject: [PATCH v3] gnu: Add fheroes2

* gnu/packages/games.scm (fheroes2): New variable.
---
 gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 79754d3185..8ad02be794 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12470,3 +12470,34 @@  wreckage.  You're stranded on a desert island and have to survive.  In order to
 do so you need to explore the island, find food, build a shelter and try to
 get attention, so you get found.")
       (license license:cc-by4.0))))
+
+(define-public fheroes2
+  (package
+    (name "fheroes2")
+    (version "0.9.7")
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
+                      "RELEASE=1")))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)))
+    (inputs
+     `(("zlib" ,zlib)
+       ("libpng" ,libpng)
+       ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ihhub/fheroes2")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0v3zh8a8yxfikcr5vkmy36c57l4nmwisz13mjavn5f7yrirf86fn"))))
+    (home-page "https://ihhub.github.io/fheroes2/")
+    (synopsis "Turn-based strategy game engine")
+    (description "Free implementation of Heroes of Might and Magic II (aka
+HOMM2) game engine.  Requires assets/game resources to play, @file{fheroes2}
+is looking for them at @file{~/.local/share/fheroes2} folder.")
+    (license license:gpl2)))
-- 
2.33.0