diff mbox series

bug#51640: [PATCH guix 0/1] [PATCH] Adds libphonenumber

Message ID 87lf10uix8.fsf_-_@gnu.org
State Accepted
Headers show
Series bug#51640: [PATCH guix 0/1] [PATCH] Adds libphonenumber | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Dec. 4, 2021, 10:03 p.m. UTC
Hi,

~rdesfo <rdesfo@git.sr.ht> skribis:

> From: Ryan Desfosses <rdes@protonmail.com>
>
> * gnu/package/messaging.scm (libphonenumber): New variable

Applied with the changes below, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 93f469a968..2e3afb510e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2791,11 +2791,11 @@  (define-public libphonenumber
                (base32
                 "06y3mh1d1mks6d0ynxp3980g712nkf8l5nyljpybsk326b246hg9"))))
    (arguments
-    `(#:tests? #f ; no tests
+    `(#:test-target "tests"
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'change-directory
-          (lambda _ (chdir "cpp") #t)))))
+          (lambda _ (chdir "cpp"))))))
    (build-system cmake-build-system)
    (native-inputs
     `(("googletest" ,googletest)
@@ -2804,8 +2804,10 @@  (define-public libphonenumber
     `(("boost" ,boost)
       ("protobuf" ,protobuf)
       ("icu4c" ,icu4c)))
-   (synopsis "Google's i18n library for parsing and using phone numbers")
-   (description "Google's i18n library for parsing and using phone numbers")
+   (synopsis "Library for parsing and using phone numbers")
+   (description
+    "This package provides a C++ library for parsing, formatting, and
+validating international phone numbers.")
    (home-page "https://github.com/google/libphonenumber")
    (license license:asl2.0)))