diff mbox series

[bug#67552] libtorrent-rasterbar tests fail [with patch]

Message ID 87leafvubv.fsf@web.de
State New
Headers show
Series [bug#67552] libtorrent-rasterbar tests fail [with patch] | expand

Commit Message

Dr. Arne Babenhauserheide Nov. 30, 2023, 8:51 p.m. UTC
Attached is a patch to disable the failing tests, so I can build
libtorrent-rasterbar locally.
Best wishes,
Arne

Comments

Tomas Volf Nov. 30, 2023, 10:21 p.m. UTC | #1
On 2023-11-30 21:51:00 +0100, Dr. Arne Babenhauserheide wrote:
> Attached is a patch to disable the failing tests, so I can build
> libtorrent-rasterbar locally.
>

I have an actual patch fixing the tests (and updating to newer version) in the
works, will send it today once I figure out how (there are many steps in the
manual).

So not sure if applying this makes sense (I don't want to handle the conflict :)
).

> From 1adbe26fefadd282d6d54ce9d03c0b2f1ae2d90b Mon Sep 17 00:00:00 2001
> Message-ID: <1adbe26fefadd282d6d54ce9d03c0b2f1ae2d90b.1701376316.git.arne_bab@web.de>
> From: Arne Babenhauserheide <arne_bab@web.de>
> Date: Thu, 30 Nov 2023 20:52:12 +0100
> Subject: [PATCH] libtorrent-rasterbar: disable locally failing tests
>
> * gnu/packages/bittorrent.scm(libtorrent-rasterbar): disable the failing tests
>   "test_fast_extension" "test_privacy" "test_resolve_links" "test_lsd"
>
> Change-Id: I7273bfb62e5d648fcfdc41586c1dd231236d965c
> ---
>  gnu/packages/bittorrent.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
> index 6f75a92cff..6597c74fd7 100644
> --- a/gnu/packages/bittorrent.scm
> +++ b/gnu/packages/bittorrent.scm
> @@ -442,7 +442,8 @@ (define-public libtorrent-rasterbar
>             (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
>               (let ((disabled-tests
>                      ;; test_upnp requires a non-localhost IPv4 interface.
> -                    '("test_upnp")))
> +                    '("test_upnp" "test_fast_extension" "test_privacy"
> +                      "test_resolve_links" "test_lsd")))
>                 (when tests?
>                   ;; test_ssl relies on bundled TLS certificates with a fixed
>                   ;; expiry date.  To ensure succesful builds in the future,
>
> base-commit: 2b782f67266b42bb40015bd23ce2443be2f9b01f
> --
> 2.41.0
>

>
> Best wishes,
> Arne




--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
Dr. Arne Babenhauserheide Nov. 30, 2023, 10:28 p.m. UTC | #2
Tomas Volf <~@wolfsden.cz> writes:
> On 2023-11-30 21:51:00 +0100, Dr. Arne Babenhauserheide wrote:
>> Attached is a patch to disable the failing tests, so I can build
>> libtorrent-rasterbar locally.
>>
>
> I have an actual patch fixing the tests (and updating to newer version) in the
> works, will send it today once I figure out how (there are many steps in the
> manual).

Very cool! Then please do *not* apply my patch!

I’m looking forward to having an updated backend to qBittorrent :-)

Thank you for taking it up — and digging deeper to the actual issue than
I did!

Best wishes,
Arne
Tomas Volf Dec. 1, 2023, 12:54 p.m. UTC | #3
Hi,

I submitted my patch set as https://debbugs.gnu.org/cgi/bugreport.cgi?bug=67557.
For some reason it seems it takes while to get through, not sure what the
problem is, but once it shows up, feel free to test it out.

Tomas

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
Jakob Kirsch Dec. 5, 2023, 6:57 p.m. UTC | #4
I hope this will be fixed soon.

"guix system reconfigure" is basically unusable for me right now since 
it just hangs at the check phase of libtorrent-rasterbar.
Ludovic Courtès Dec. 7, 2023, 9:01 a.m. UTC | #5
Hi!

Tomas Volf <~@wolfsden.cz> skribis:

> I submitted my patch set as https://debbugs.gnu.org/cgi/bugreport.cgi?bug=67557.
> For some reason it seems it takes while to get through, not sure what the
> problem is, but once it shows up, feel free to test it out.

I applied Tomas’ update from <https://issues.guix.gnu.org/67557> and
everything built fine on my x86_64 machine, but test fails at ci.guix.
From <https://ci.guix.gnu.org/build/2804230/log>:

--8<---------------cut here---------------start------------->8---
100% tests passed, 0 tests failed out of 104

Total Test time (real) = 759.05 sec
Test project /tmp/guix-build-libtorrent-rasterbar-2.0.9.drv-0/build
    Start 75: test_ssl
1/1 Test #75: test_ssl .........................***Timeout 600.11 sec
test: /tmp/guix-build-libtorrent-rasterbar-2.0.9.drv-0/build/test/test_ssl
cwd_prefix = "/tmp/guix-build-libtorrent-rasterbar-2.0.9.drv-0/build/test/test_tmp_7352_"


0% tests passed, 1 tests failed out of 1

Total Test time (real) = 600.11 sec

The following tests FAILED:
	 75 - test_ssl (Timeout)
Errors while running CTest
--8<---------------cut here---------------end--------------->8---

I don’t think Arne’s patch addresses this, right?

Let me know what you think should be done.

Cheers,
Ludo’.
diff mbox series

Patch

From 1adbe26fefadd282d6d54ce9d03c0b2f1ae2d90b Mon Sep 17 00:00:00 2001
Message-ID: <1adbe26fefadd282d6d54ce9d03c0b2f1ae2d90b.1701376316.git.arne_bab@web.de>
From: Arne Babenhauserheide <arne_bab@web.de>
Date: Thu, 30 Nov 2023 20:52:12 +0100
Subject: [PATCH] libtorrent-rasterbar: disable locally failing tests

* gnu/packages/bittorrent.scm(libtorrent-rasterbar): disable the failing tests
  "test_fast_extension" "test_privacy" "test_resolve_links" "test_lsd"

Change-Id: I7273bfb62e5d648fcfdc41586c1dd231236d965c
---
 gnu/packages/bittorrent.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 6f75a92cff..6597c74fd7 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -442,7 +442,8 @@  (define-public libtorrent-rasterbar
            (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
              (let ((disabled-tests
                     ;; test_upnp requires a non-localhost IPv4 interface.
-                    '("test_upnp")))
+                    '("test_upnp" "test_fast_extension" "test_privacy"
+                      "test_resolve_links" "test_lsd")))
                (when tests?
                  ;; test_ssl relies on bundled TLS certificates with a fixed
                  ;; expiry date.  To ensure succesful builds in the future,

base-commit: 2b782f67266b42bb40015bd23ce2443be2f9b01f
-- 
2.41.0