bug#33853: [PATCH] gnu: Add font-mononoki.

Message ID 87k1jzeytq.fsf@gnu.org
State Accepted
Headers show
Series bug#33853: [PATCH] gnu: Add font-mononoki. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès Dec. 24, 2018, 3:20 p.m. UTC
Hello Gabriel,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

> * gnu/packages/fonts.scm (font-mononoki): New variable.

Thanks for the patch!  I made the changes below on your behalf.  The
‘git-fetch’ bit is to avoid relying on tarballs generated by github.com
since they can change over time.

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b4ca0cfd10..88315008bd 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
 ;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1357,19 +1358,18 @@  files (TTF).")
     (name "font-mononoki")
     (version "1.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/madmalik/mononoki/archive/"
-                    version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/madmalik/mononoki/")
+                    (commit version)))
               (sha256
                (base32
-                "14bd2sk6z24kq5q8wyr1vcjr380vvjdm5i7zqa0f0ynk9jkz57qq"))
-              (file-name (string-append "font-mononoki-"
-                                        version ".tar.gz"))))
+                "1rkzyxn30rn8qv2h2xz324j7q15hzg2lci8790a7cdl1dfgic4xi"))
+              (file-name (git-file-name name version))))
     (build-system font-build-system)
     (synopsis "Font for programming and code review")
     (description
      "Mononoki is a typeface by Matthias Tellen, created to enhance code
-formatting")
+formatting.")
     (home-page "https://madmalik.github.io/mononoki/")
     (license license:silofl1.1)))