[bug#33951] gnu: cmake-extra-modules: Fix QTPLUGINDIR.

Message ID 87k1jns7mm.fsf@gmail.com
State Accepted
Headers show
Series [bug#33951] gnu: cmake-extra-modules: Fix QTPLUGINDIR. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Meiyo Peng Jan. 2, 2019, 9:58 a.m. UTC
Hi,

This patch fixes the regular expression for QTPLUGINDIR.

The source code of "kde-modules/KDEInstallDirs.cmake" has been changed
by upstream in recent releases.  This regular expression bug caused
dependent packages install qt plugins into a wrong directory.
--
Meiyo Peng
https://www.pengmeiyu.com/

Patch

From a242fed166b0939365a6e6f3259c65471dc01db7 Mon Sep 17 00:00:00 2001
From: Meiyo Peng <meiyo.peng@gmail.com>
Date: Sat, 29 Dec 2018 00:06:00 +0800
Subject: [PATCH] gnu: cmake-extra-modules: Fix QTPLUGINDIR.

* gnu/packages/kde-frameworks.scm (cmake-extra-modules)[arguments]: Fix
  QTPLUGINDIR.
---
 gnu/packages/kde-frameworks.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6c1854379..5c21a7fb7 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -98,7 +99,7 @@ 
                (("\"lib64\"") "\"lib\"")
                ;; TODO: Base the following on values taken from Qt
                ;; Install plugins into lib/qt5/plugins
-               (("_define_relative\\(QTPLUGINDIR LIBDIR \"plugins\"")
+               (("_define_relative\\(QTPLUGINDIR \"\\$\\{_pluginsDirParent\\}\" \"plugins\"")
                 "_define_relative(QTPLUGINDIR LIBDIR \"qt5/plugins\"")
                ;; Install imports into lib/qt5/imports
                (("_define_relative\\(QTQUICKIMPORTSDIR QTPLUGINDIR \"imports\"")
-- 
2.20.1