From 19baad3823d0d4051b51def372b119cbf52983a8 Mon Sep 17 00:00:00 2001
From: gabrielhdt <gabrielhondet@gmail.com>
Date: Sat, 11 May 2019 22:11:40 +0200
Subject: [PATCH] gnu: Add emacs-ediprolog.
* gnu/packages/emacs-xyz.scm (emacs-ediprolog): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -15510,3 +15510,27 @@ numbers within that region will be incremented/decremented (unlike in Vim).
It is a fork of https://github.com/cofi/evil-numbers, which is unmaintained.")
(license license:gpl3+))))
+
+(define-public emacs-ediprolog
+ (package
+ (name "emacs-ediprolog")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/ediprolog-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "039ffvp7c810mjyargmgw1i87g0z8qs8qicq826sd9aiz9hprfaz"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/ediprolog.html")
+ (synopsis "Emacs Does Interactive Prolog")
+ (description "This package provides a major mode that let the user
+interact with SWI-Prolog in all buffers. For instance, one can consult Prolog
+programs and evaluate embedded queries. This mode is focused on the command
+@code{ediprolog-dwim} (Do What I Mean) which is supposed to, depending on the
+context, carry out the appropriate action.")
+ (license license:gpl3+)))
--
2.21.0