diff mbox series

[bug#37379,core-updates] gnu: glib: Reference dbus-launch by its absolute path.

Message ID 87k1afqaha.fsf@gmail.com
State Accepted
Headers show
Series [bug#37379,core-updates] gnu: glib: Reference dbus-launch by its absolute path. | expand

Commit Message

Maxim Cournoyer Sept. 11, 2019, 12:32 p.m. UTC
Hello,

This allows programs or libraries compiled with glib to connect to dbus
without having the 'dbus-launch' binary present (propagated) into their
profile.

dbus triggers lots of rebuilds, so this should be merged to the
core-updates branch.

Thank you,

Maxim

Comments

Danny Milosavljevic Oct. 1, 2019, 11:41 p.m. UTC | #1
LGTM!
Maxim Cournoyer Oct. 2, 2019, 2:46 p.m. UTC | #2
Hello Danny!

Danny Milosavljevic <dannym@scratchpost.org> writes:

> LGTM!

Thank you for the review.  I'll delay merging this into core-updates
until it has been merged to master (which should be imminent).

Maxim
Maxim Cournoyer Oct. 21, 2019, 3:04 a.m. UTC | #3
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello Danny!
>
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
>> LGTM!
>
> Thank you for the review.  I'll delay merging this into core-updates
> until it has been merged to master (which should be imminent).
>
> Maxim

Pushed to core-updates as 7da3e81aa1.

Closing,

Maxim
diff mbox series

Patch

From 1881ad1305f55f3bf7ac7a48ea1c76123f2864b2 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 10 Sep 2019 11:02:16 +0900
Subject: [PATCH] gnu: glib: Reference dbus-launch by its absolute path.

* gnu/packages/glib.scm (glib)[phases]{patch-dbus-launch-path}: New phase.
---
 gnu/packages/glib.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 3a50347f86..fb148eec19 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -199,6 +199,14 @@  shared NFS home directories.")
    (arguments
     `(#:phases
       (modify-phases %standard-phases
+        (add-after 'unpack 'patch-dbus-launch-path
+          (lambda* (#:key inputs #:allow-other-keys)
+            (let ((dbus (assoc-ref inputs "dbus")))
+              (substitute* "gio/gdbusaddress.c"
+                (("command_line = g_strdup_printf \\(\"dbus-launch")
+                 (string-append "command_line = g_strdup_printf (\""
+                                dbus "/bin/dbus-launch")))
+              #t)))
         (add-before 'build 'pre-build
           (lambda* (#:key inputs outputs #:allow-other-keys)
             ;; For tests/gdatetime.c.
-- 
2.23.0