diff mbox series

[bug#38409] gnu: Add emacs-mpdel.

Message ID 87k17kpkol.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#38409] gnu: Add emacs-mpdel. | expand

Commit Message

LaFreniere, Joseph Nov. 28, 2019, 6:41 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Brett Gilio Dec. 7, 2019, 2:18 a.m. UTC | #1
Hi Joseph,

I have applied your patches with commits:
e5f145b4e9bc466736f690d7c26be81c6922c4a5
abda9e2d11217cfe7afde8dcc5ebfc988eaa9406.

I made an edit because libmpdel seems to be under GPL3 or
later. Otherwise, the patches looked good and there were no comments
citing any issues.

For future, you might look into how to send a patch series. They tend to
be easier to understand the patch application order.

Thank you for your work!
Brett Gilio Dec. 7, 2019, 2:21 a.m. UTC | #2
Brett Gilio <brettg@posteo.net> writes:

> Hi Joseph,
>
> I have applied your patches with commits:
> e5f145b4e9bc466736f690d7c26be81c6922c4a5
> abda9e2d11217cfe7afde8dcc5ebfc988eaa9406.
>
> I made an edit because libmpdel seems to be under GPL3 or
> later. Otherwise, the patches looked good and there were no comments
> citing any issues.
>
> For future, you might look into how to send a patch series. They tend to
> be easier to understand the patch application order.
>
> Thank you for your work!

close
diff mbox series

Patch

From d7c9adb9e8e16765e422851535c9cb22e69a1f38 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Thu, 28 Nov 2019 00:32:54 -0600
Subject: [PATCH] gnu: Add emacs-mpdel.

* gnu/packages/emacs-xyz.scm (emacs-mpdel): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c60221b38..97798c1f24 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17255,6 +17255,31 @@  comments.")
 flexible, powerful, server-side application for playing music.")
     (license license:gpl3)))
 
+(define-public emacs-mpdel
+  (package
+    (name "emacs-mpdel")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitea.petton.fr/mpdel/mpdel.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0pyyvbzskr44dxbmlp3y0r6s459fd51cvwjmnjaqxfxflr5v891g"))))
+    (build-system emacs-build-system)
+    (inputs
+     `(("emacs-libmpdel" ,emacs-libmpdel)))
+    (home-page "https://gitea.petton.fr/mpdel/mpdel")
+    (synopsis "Emacs user interface for Music Player Daemon (MPD)")
+    (description
+     "MPDel provides an Emacs user interface to control playback (play, pause,
+next, volume) and display and control the current playlist as well as your
+stored playlists.")
+    (license license:gpl3+)))
+
 (define-public emacs-simple-mpc
   ;; There have been no releases.
   (let ((commit "bee8520e81292b4c7353e45b193f9a13b482f5b2")
-- 
2.24.0