diff mbox series

[bug#40035] Add widelands game

Message ID 87k13pkku4.fsf@posteo.mx
State Accepted
Headers show
Series [bug#40035] Add widelands game | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alberto EFG March 13, 2020, 3:14 a.m. UTC
I added all the changes. The synopsis is slightly different than
requested, because of character length.

Comments

Nicolas Goaziou March 13, 2020, 8:16 a.m. UTC | #1
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

> I added all the changes. The synopsis is slightly different than
> requested, because of character length.

Thanks!

> +(define-public widelands
> +  (package
> +    (name "widelands")
> +    (version "20")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://launchpad.net/widelands/build20/build20/+download/"
> +                           name "-build" version ".tar.bz2"))

I suggest to use version everywhere in the `uri' string:

  (string-append "https://launchpad.net/widelands/build" version "/build" version "/" ...)

> +    (description
> +     "Widelands is a strategy game aiming for gameplay similar to Settlers II by
> +    BlueByte.
> +
> +    In this game, you start out on a small piece of land with nothing more than
> +    a few of useful resources.  Using those, you can build yourself an empire
> +    with many thousands of inhabitants.  On your way towards this goal, you will
> +    have to build up an economic infrastructure, explore the lands around you
> +    and face enemies who are trying to rule the world just like you do.")

The description should not be indented.

> +    (license (list
> +              license:gpl2+
> +              license:gpl3+
> +              license:expat
> +              license:zlib
> +              license:silofl1.1
> +              license:asl2.0
> +              license:cc-by-sa3.0))))

I suggest to add a comment explaining that the software, as a whole, is
gpl2+, but assets are released under various licenses.

BTW, the source ships with "minizip" and "gettext" in "src/third_party".
Could you try unbundling them and use the ones provided by Guix?

Otherwise, LGTM!

Regards,
diff mbox series

Patch

From f8b1cf1bbfe49ab9ae683a89bbeda23b363689fa Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Wed, 11 Mar 2020 21:50:14 -0600
Subject: [PATCH] gnu: Add widelands.

* gnu/packages/games.scm (widelands): New variable.
---
 gnu/packages/games.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 322e309591..eb61341794 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -46,6 +46,7 @@ 
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10157,3 +10158,55 @@  best human chess grandmasters.  It can be used with UCI-compatible GUIs like
 ChessX.")
     (home-page "https://stockfishchess.org/")
     (license license:gpl3+)))
+
+(define-public widelands
+  (package
+    (name "widelands")
+    (version "20")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://launchpad.net/widelands/build20/build20/+download/"
+                           name "-build" version ".tar.bz2"))
+       (sha256
+        (base32 "1cmwfwk7j6yi2pwmm4rm57s23sdzasqf53nx6567sdagqyc4sn9q"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags
+       (let* ((out (assoc-ref %outputs "out"))
+              (share (string-append out "/share")))
+         (list    "-DCMAKE_BUILD_TYPE=Release"
+                  (string-append "-DCMAKE_INSTALL_PREFIX=" out "/bin")
+                  (string-append "-DWL_INSTALL_BASEDIR=" share "/widelands")
+                  (string-append "-DWL_INSTALL_DATADIR=" share "/widelands")
+                  "-DOPTION_BUILD_WEBSITE_TOOLS=OFF"))))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("python" ,python)))
+    (inputs
+     `(("boost" ,boost)
+       ("glew" ,glew)
+       ("icu4c" ,icu4c)
+       ("libpng" ,libpng)
+       ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))
+       ("zlib" ,zlib)))
+    (home-page "https://www.widelands.org/")
+    (synopsis "Real-time strategy game with singleplayer campaigns and
+ multiplayer mode")
+    (description
+     "Widelands is a strategy game aiming for gameplay similar to Settlers II by
+    BlueByte.
+
+    In this game, you start out on a small piece of land with nothing more than
+    a few of useful resources.  Using those, you can build yourself an empire
+    with many thousands of inhabitants.  On your way towards this goal, you will
+    have to build up an economic infrastructure, explore the lands around you
+    and face enemies who are trying to rule the world just like you do.")
+    (license (list
+              license:gpl2+
+              license:gpl3+
+              license:expat
+              license:zlib
+              license:silofl1.1
+              license:asl2.0
+              license:cc-by-sa3.0))))
-- 
2.25.1