diff mbox series

[bug#41252] gnu: emacs-org-re-reveal: Update to 2.12.2.

Message ID 87k11eho6u.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41252] gnu: emacs-org-re-reveal: Update to 2.12.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 14, 2020, 9:15 a.m. UTC
To test this, I made a presentation about guix git workflow in emacs:
https://www.rohleder.de/~mike/guix-workflow/

maybe, its useful for someone.
love, peace and harmony!

Comments

Nicolas Goaziou May 14, 2020, 9:22 a.m. UTC | #1
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> To test this, I made a presentation about guix git workflow in emacs:
> https://www.rohleder.de/~mike/guix-workflow/

Nice.

> Subject: [PATCH] gnu: emacs-org-re-reveal: Update to 2.12.2.
>
> * gnu/packages/emacs-xyz.scm (emacs-org-re-reveal): Update to 2.12.2.

Applied. Thank you.

Regards,
Simon Tournier May 14, 2020, 10:02 a.m. UTC | #2
Dear Michael,

On Thu, 14 May 2020 at 11:17, Michael Rohleder <mike@rohleder.de> wrote:

> To test this, I made a presentation about guix git workflow in emacs:
> https://www.rohleder.de/~mike/guix-workflow/

Nice!

Just one minor comment, instead of this long '--ad-hoc' line, you
should use a manifest file.

#+BEGIN_SRC shell
guix environment -C -N -E TERM guix --expose=/var/guix=/var/guix \
--ad-hoc emacs-no-x emacs-magit git git:send-email emacs-yasnippet
help2man pkg-config guile \
-- emacs --execute "(load-theme 'wombat)"
#+END_SRC

#+BEGIN_SRC shell
guix environment -C -N -E TERM guix --expose=/var/guix=/var/guix \
-m my-manifest.scm \
-- emacs --execute "(load-theme 'wombat)"
#+END_SRC

--8<---------------cut here---------------start------------->8---
(specifications->manifest
   '("emacs-no-x" "emacs-magit"
     "git" "git:send-email"
     "emacs-yasnippet"
     "help2man" "pkg-config guile"))
--8<---------------cut here---------------end--------------->8---

The main advantages are:
 - version control the file
 - reuse elsewhere, for example "guix install"
 - easy to locally extend:
   guix environment -m my-manifest --ad-hoc emacs-evil


Well, thank you for sharing and for the update.

All the best,
simon
Michael Rohleder May 14, 2020, 10:45 a.m. UTC | #3
Hey zimon!

zimoun <zimon.toutoune@gmail.com> writes:
> Just one minor comment, instead of this long '--ad-hoc' line, you
> should use a manifest file.

thank you for your suggestion!

I wanted to keep this presentation "file free", meaning, I didnt want
that the reader needs to download any files.
(some thing for a .emacs init file...).
Simon Tournier May 14, 2020, 4:41 p.m. UTC | #4
On Thu, 14 May 2020 at 12:45, Michael Rohleder <mike@rohleder.de> wrote:

> I wanted to keep this presentation "file free", meaning, I didnt want
> that the reader needs to download any files.
> (some thing for a .emacs init file...).

I understand.  Depend on the audience:

--8<---------------cut here---------------start------------->8---
cat > /tmp/manif.scm<<EOF
(specifications->manifest
   '("emacs-no-x" "emacs-magit"
     "git" "git:send-email"
     "emacs-yasnippet"
     "help2man" "pkg-config guile"))
EOF
guix environment -m /tmp/manifest.scm
--8<---------------cut here---------------end--------------->8---


All the best,
simon
diff mbox series

Patch

From 528ccdab63cf399012582450491be6df3d8cc431 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 14 May 2020 08:16:49 +0000
Subject: [PATCH] gnu: emacs-org-re-reveal: Update to 2.12.2.

* gnu/packages/emacs-xyz.scm (emacs-org-re-reveal): Update to 2.12.2.
---
 gnu/packages/emacs-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 264fb2a1d7..415669b30f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14567,7 +14567,7 @@  powerful Org contents.")
 (define-public emacs-org-re-reveal
   (package
     (name "emacs-org-re-reveal")
-    (version "2.5.1")
+    (version "2.12.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -14576,7 +14576,7 @@  powerful Org contents.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1zbz6hbddxbb264ibmhc04cmnpk17kb50jpn5l8878q4hxw5wwy2"))))
+                "19nz77f2r49hqavz50ri222prhrd5890vhvc7jfazbascbcdjbqv"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-htmlize" ,emacs-htmlize)
-- 
2.26.2