diff mbox series

[bug#41395,2/3] gnu: Remove python-prompt-toolkit-1

Message ID 87k10yylc4.fsf@alice.lan
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Edouard Klein May 26, 2020, 11:41 a.m. UTC
* gnu/packages/python-xyz.scm (python-prompt-toolkit-1): Remove variable.
---
 gnu/packages/python-xyz.scm | 14 --------------
 1 file changed, 14 deletions(-)

Comments

Edouard Klein May 26, 2020, 1:41 p.m. UTC | #1
Please disregard this patch, as it turns out that
python2-jupyter-console and python2-ipython still depend on
python2-prompt-toolkit-1.

My apologies for this mistake (and many thanks to Tobias for figuring it
out).

Edouard Klein writes:

> * gnu/packages/python-xyz.scm (python-prompt-toolkit-1): Remove variable.
> ---
>  gnu/packages/python-xyz.scm | 14 --------------
>  1 file changed, 14 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 76a1635b12..04cfb98eef 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -12144,20 +12144,6 @@ characters, mouse support, and auto suggestions.")
>  (define-public python2-prompt-toolkit
>    (package-with-python2 python-prompt-toolkit))
>  
> -(define-public python-prompt-toolkit-1
> -  (package (inherit python-prompt-toolkit)
> -    (version "1.0.15")
> -    (source
> -     (origin
> -       (method url-fetch)
> -       (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
> -       (sha256
> -        (base32
> -         "05v9h5nydljwpj5nm8n804ms0glajwfy1zagrzqrg91wk3qqi1c5"))))))
> -
> -(define-public python2-prompt-toolkit-1
> -  (package-with-python2 python-prompt-toolkit-1))
> -
>  (define-public python-jedi
>    (package
>      (name "python-jedi")
Marius Bakke May 30, 2020, 1:26 p.m. UTC | #2
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/python-xyz.scm (python-prompt-toolkit-1): Remove variable.

This also removes 'python2-prompt-toolkit-1' contrary to what the commit
message says.  Unfortunately that variable is still in use.  So I
skipped this patch for now.
Marius Bakke May 30, 2020, 1:27 p.m. UTC | #3
Edouard Klein <edou@rdklein.fr> writes:

> Please disregard this patch, as it turns out that
> python2-jupyter-console and python2-ipython still depend on
> python2-prompt-toolkit-1.
>
> My apologies for this mistake (and many thanks to Tobias for figuring it
> out).

Oh, I should learn to read the entire patch series instead of applying
them one-by-one...  :-P
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 76a1635b12..04cfb98eef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12144,20 +12144,6 @@  characters, mouse support, and auto suggestions.")
 (define-public python2-prompt-toolkit
   (package-with-python2 python-prompt-toolkit))
 
-(define-public python-prompt-toolkit-1
-  (package (inherit python-prompt-toolkit)
-    (version "1.0.15")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
-       (sha256
-        (base32
-         "05v9h5nydljwpj5nm8n804ms0glajwfy1zagrzqrg91wk3qqi1c5"))))))
-
-(define-public python2-prompt-toolkit-1
-  (package-with-python2 python-prompt-toolkit-1))
-
 (define-public python-jedi
   (package
     (name "python-jedi")