diff mbox series

[bug#43134] gnu: Update node to 10.22.0.

Message ID 87k0xff1db.fsf@gmx.com
State Accepted
Headers show
Series [bug#43134] gnu: Update node to 10.22.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Langlois Aug. 31, 2020, 12:25 p.m. UTC
Hi Guix!

Sadly it's a little complicated to update node to the current 14.x
series, see https://lists.gnu.org/archive/html/guix-patches/2020-07/msg00965.html

In the meantime though, we can update the 10.x series still, it's in
maintenance mode, but still supported until April 2021 [0].

Note that this version expects symbols that are only in nghttp2 1.41 so
we need to explicitly update it instead of relying on grafting otherwise
it doesn't build.

Thanks!
Pierre
[0]: https://github.com/nodejs/Release#release-schedule

Comments

Mathieu Othacehe Sept. 3, 2020, 5:42 a.m. UTC | #1
Hello Pierre,

> Sadly it's a little complicated to update node to the current 14.x
> series, see https://lists.gnu.org/archive/html/guix-patches/2020-07/msg00965.html
>
> In the meantime though, we can update the 10.x series still, it's in
> maintenance mode, but still supported until April 2021 [0].

Thanks for explaining the context. This LGTM, feel free to proceed :).

Mathieu
Pierre Langlois Sept. 4, 2020, 11:16 a.m. UTC | #2
Mathieu Othacehe writes:

> Hello Pierre,
>
>> Sadly it's a little complicated to update node to the current 14.x
>> series, see https://lists.gnu.org/archive/html/guix-patches/2020-07/msg00965.html
>>
>> In the meantime though, we can update the 10.x series still, it's in
>> maintenance mode, but still supported until April 2021 [0].
>
> Thanks for explaining the context. This LGTM, feel free to proceed :).

Thanks Mathieu, pushed with 235093fec0daf3563e21036d74c250d4770ffc77 !
diff mbox series

Patch

From 0a0ec033a492af5964b5ca5c08c55b776f426314 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Thu, 27 Aug 2020 02:53:45 +0100
Subject: [PATCH] gnu: Update node to 10.22.0.

* gnu/packages/node.scm (node): Update to 10.22.0.
[inputs]: Replace nghttp2 with nghttp2-1.41.
---
 gnu/packages/node.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 1adb2cd07f..ed0b5c4f16 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,14 +47,14 @@ 
 (define-public node
   (package
     (name "node")
-    (version "10.19.0")
+    (version "10.22.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.xz"))
               (sha256
                (base32
-                "0sginvcsf7lrlzsnpahj4bj1f673wfvby8kaxgvzlrbb7sy229v2"))
+                "1nz18fa550li10r0kzsm28c2rvvq61nq8bqdygip0rmvbi2paxg0"))
               (modules '((guix build utils)))
               (snippet
                `(begin
@@ -185,7 +186,7 @@ 
        ("http-parser" ,http-parser)
        ("icu4c" ,icu4c)
        ("libuv" ,libuv)
-       ("nghttp2" ,nghttp2 "lib")
+       ("nghttp2" ,nghttp2-1.41 "lib")
        ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (synopsis "Evented I/O for V8 JavaScript")
-- 
2.28.0