diff mbox series

bug#43620: [PATCH 2/2] gnu: Add folly.

Message ID 87k0vxhk55.fsf@gnu.org
State Accepted
Headers show
Series bug#43620: [PATCH 2/2] gnu: Add folly. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Oct. 10, 2020, 8:59 p.m. UTC
Greg Hogan <code@greghogan.com> skribis:

>>From 8e3df10ad8aa791e34a5a5abcaabe0438f7b063a Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 22 Sep 2020 15:22:32 +0000
> Subject: [PATCH] gnu: Add folly.
>
> * gnu/packages/cpp.scm (folly): New variable.

Applied with the changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7f52dc3772..da3ea8ec55 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -697,8 +697,7 @@  standard GNU style syntax for options.")
     (build-system cmake-build-system)
     (arguments
      '(;; Tests must be explicitly enabled
-       ;#:configure-flags
-       ;'("-DBUILD_TESTS=ON")))
+       ;;#:configure-flags '("-DBUILD_TESTS=ON")))
        ;; Leave tests disabled; see https://github.com/facebook/folly/issues/1456
        #:tests? #f))
     (propagated-inputs
@@ -725,8 +724,8 @@  standard GNU style syntax for options.")
     (synopsis "Collection of C++ components complementing the standard library")
     (description
      "Folly (acronymed loosely after Facebook Open Source Library) is a library
-of C++14 components which complements @code{std} and Boost.")
+of C++14 components that complements @code{std} and Boost.")
     (home-page "https://github.com/facebook/folly/wiki")
-    ; 32-bit is not supported: https://github.com/facebook/folly/issues/103
-    (supported-systems '("aarch64" "x86_64-linux"))
+    ;; 32-bit is not supported: https://github.com/facebook/folly/issues/103
+    (supported-systems '("aarch64-linux" "x86_64-linux"))
     (license license:asl2.0)))