diff mbox series

[bug#46083] gnu: ghc-8.8: Update to 8.8.4.

Message ID 87k0s2grpd.fsf@localhost
State Accepted
Headers show
Series [bug#46083] gnu: ghc-8.8: Update to 8.8.4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

itd Jan. 24, 2021, 5:39 p.m. UTC
* gnu/packages/patches/ghc-hsc2hs-default-compiler.patch: New file.
* gnu/packages/haskell.scm (ghc-8.8): Update to 8.8.4
[source]: Add new patch.
---
Hi,

please consider updating ghc-8.8 to version 8.8.4.  Below a possible
patch for that.  Feedback appreciated.

Without the new patch some tests failed with output "Can't find cc":

> Unexpected failures:
>    ffi/should_run/Capi_Ctype_001.run          Capi_Ctype_001 [bad exit code] (normal)
>    ffi/should_run/Capi_Ctype_002.run          Capi_Ctype_002 [bad exit code] (normal)
>    hsc2hs/hsc2hs001.run                       hsc2hs001 [bad exit code] (normal)
>    hsc2hs/hsc2hs002.run                       hsc2hs002 [bad exit code] (normal)
>    hsc2hs/hsc2hs003.run                       hsc2hs003 [bad exit code] (normal)
>    hsc2hs/hsc2hs004.run                       hsc2hs004 [bad exit code] (normal)
>    hsc2hs/T3837.run                           T3837 [bad exit code] (normal)
>    hsc2hs/T4340.run                           T4340 [bad exit code] (normal)
>    hsc2hs/T10272.run                          T10272 [bad exit code] (normal)
>    hsc2hs/T11004.run                          T11004 [bad exit code] (normal)
>    hsc2hs/T12504.run                          T12504 [bad exit code] (normal)
>    hsc2hs/T15758.run                          T15758 [bad exit code] (normal)
>    libraries/base/tests/IO/T12010/T12010.run  T12010 [bad exit code] (threaded1)

Thanks.

Best regards
itd

 gnu/packages/haskell.scm                          |  7 ++++---
 .../patches/ghc-hsc2hs-default-compiler.patch     | 15 +++++++++++++++
 2 files changed, 19 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/patches/ghc-hsc2hs-default-compiler.patch

Comments

itd Oct. 17, 2021, 12:18 a.m. UTC | #1
Current Guix has updated ghc.
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09732fc594..494acbf88a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -613,14 +613,15 @@  interactive environment for the functional language Haskell.")
 (define-public ghc-8.8
   (package (inherit ghc-8.6)
     (name "ghc")
-    (version "8.8.3")
+    (version "8.8.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.haskell.org/ghc/dist/"
                            version "/ghc-" version "-src.tar.xz"))
+       (patches (search-patches "ghc-hsc2hs-default-compiler.patch"))
        (sha256
-        (base32 "128g932i3wix6ic03v04nh5755vyjiidzri9iybwad72yfmc1p70"))))
+        (base32 "0bgwbxxvdn56l91bp9p5d083gzcfdi6z8l8b17qzjpr3n8w5wl7h"))))
     (native-inputs
      `(("ghc-bootstrap" ,ghc-8.6)
        ("ghc-testsuite"
@@ -632,7 +633,7 @@  interactive environment for the functional language Haskell.")
            (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
            (sha256
             (base32
-             "1l32mp94ll72skfsq1g2fqax4bkiw8b85gr3wd0bbqsqyi9a9jpr"))))
+             "0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
        ("git" ,git)                     ; invoked during tests
        ,@(filter (match-lambda
                    (("ghc-bootstrap" . _) #f)
diff --git a/gnu/packages/patches/ghc-hsc2hs-default-compiler.patch b/gnu/packages/patches/ghc-hsc2hs-default-compiler.patch
new file mode 100644
index 0000000000..72f9049463
--- /dev/null
+++ b/gnu/packages/patches/ghc-hsc2hs-default-compiler.patch
@@ -0,0 +1,15 @@ 
+GCC does not provide "cc" on guix.  Hence, look for "gcc" instead.
+
+diff --git a/utils/hsc2hs/Common.hs b/utils/hsc2hs/Common.hs
+index 50471b1..c8bd297 100644
+--- a/utils/hsc2hs/Common.hs
++++ b/utils/hsc2hs/Common.hs
+@@ -20,7 +20,7 @@ die :: String -> IO a
+ die s = hPutStr stderr s >> exitWith (ExitFailure 1)
+ 
+ default_compiler :: String
+-default_compiler = "cc"
++default_compiler = "gcc"
+ 
+ ------------------------------------------------------------------------
+ -- Write the output files.