diff mbox series

bug#54753: [PATCH] gnu: Add smtpmail

Message ID 87k0buarwx.fsf@gnu.org
State Accepted
Headers show
Series bug#54753: [PATCH] gnu: Add smtpmail | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès April 12, 2022, 9:54 p.m. UTC
Hi,

Justin Veilleux <terramorpha@cock.li> skribis:

> From c1c1dea4834c47adf7269070831696f28ffb949d Mon Sep 17 00:00:00 2001
> From: terramorpha <terramorpha@cock.li>
> Date: Wed, 6 Apr 2022 13:11:52 -0400
> Subject: [PATCH] gnu: Add smtpmail.
>
> * gnu/packages/mail.scm (smtpmail): New variable.

Applied with the changes below.  License is ‘gpl2+’ because source file
headers says “or any later version”.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6dc8db526f..5dd7f3b33e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4606,17 +4606,15 @@  (define-public smtpmail
     (source
      (origin
        (method url-fetch)
-       (uri
-        (string-append
-         "http://download.savannah.nongnu.org/releases/smtpmail/smtpmail-"
-         version
-         ".tar.gz"))
-       (sha256 (base32 "08ap2l2g2avkq2jx05jy993517vvapmypg7j5cwl8gvpq436gdh5"))))
+       (uri (string-append "mirror://savannah/smtpmail/smtpmail-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "08ap2l2g2avkq2jx05jy993517vvapmypg7j5cwl8gvpq436gdh5"))))
     (build-system gnu-build-system)
     (home-page "https://www.nongnu.org/smtpmail/")
     (synopsis "SMTP utility")
     (description
      "smtpmail is a little console-based tool for users who have no local
-mailserver on her machine. it enables these users to send their mail over a
-remote smtp server.")
-    (license license:gpl2)))
+mailserver on their machine.  It enables these users to send their mail over a
+remote SMTP server.")
+    (license license:gpl2+)))