diff mbox series

[bug#57726] gnu: Add java-eclipse-sisu-maven-plugin.

Message ID 87k06ajmx0.fsf@gmail.com
State Accepted
Headers show
Series [bug#57726] gnu: Add java-eclipse-sisu-maven-plugin. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov Sept. 11, 2022, 9:11 a.m. UTC
Hello,

this patch adds "java-eclipse-sisu-maven-plugin". [1]
The patch requires "slf4j-nop" package:
  https://debbugs.gnu.org/cgi/bugreport.cgi?bug=57724

Thanks,
- Artyom

References:
1. https://github.com/eclipse/sisu.mojos

Comments

Julien Lepiller Sept. 11, 2022, 10:05 a.m. UTC | #1
The name implies this is a plugin for maven. The way you build it, maven will not be able to use it because it's missing some metadata.

You can use generate-plugin.xml to generate the required file. The parser might not work properly, I'll have a look if it doesn't work, but that might take some time.

Le 11 septembre 2022 11:11:23 GMT+02:00, "Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :
>Hello,
>
>this patch adds "java-eclipse-sisu-maven-plugin". [1]
diff mbox series

Patch

From a39872e7029433fe0ba0198dbfdf7182015a74fc Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 11 Sep 2022 12:02:27 +0300
Subject: [PATCH] gnu: Add java-eclipse-sisu-maven-plugin.

* gnu/packages/java.scm (java-eclipse-sisu-maven-plugin): New variable.
---
 gnu/packages/java.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 45c3b423f0..0445e45681 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13400,6 +13400,44 @@  (define-public java-eclipse-sisu-inject
 OSGi Service Registry is a goal of this project.")
     (license license:epl1.0)))
 
+(define-public java-eclipse-sisu-maven-plugin
+  (package
+    (name "java-eclipse-sisu-maven-plugin")
+    (version "0.3.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/eclipse/sisu.mojos/")
+                    (commit (string-append "releases/" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00hb7v6hz8jg0mgkj3cl0nmqz49za4k2a0rbjr4gdhy2m7f34sq3"))))
+    (build-system ant-build-system)
+    (arguments
+     (list #:jar-name "eclipse-sisu-maven-plugin.jar"
+           #:source-dir "src"
+           #:tests? #f ;no tests
+           #:phases #~(modify-phases %standard-phases
+                        (replace 'install
+                          (install-from-pom "pom.xml")))))
+    (propagated-inputs (list java-sonatype-oss-parent-pom-9))
+    (inputs (list maven-artifact
+                  maven-plugin-api
+                  maven-plugin-annotations
+                  maven-core
+                  maven-common-artifact-filters
+                  java-slf4j-nop
+                  java-eclipse-sisu-inject
+                  java-plexus-utils
+                  java-plexus-build-api
+                  java-slf4j-api))
+    (home-page "https://www.eclipse.org/sisu/")
+    (synopsis "Maven plugin that generates annotation indexes for Sisu")
+    (description "Maven plugin that generates annotation indexes for Sisu to
+avoid classpath scanning at runtime.")
+    (license license:epl1.0)))
+
 (define java-sisu-inject-parent-pom
   (package
     (inherit java-eclipse-sisu-inject)
-- 
2.34.1